package/ruby: enable openssl for host-ruby
authorNicolas Carrier <nicolas.carrier@orolia.com>
Fri, 25 Oct 2019 13:37:20 +0000 (13:37 +0000)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 25 Oct 2019 14:51:42 +0000 (16:51 +0200)
Openssl is required so that Gem can install ruby gems from secure websites.

ERROR:  While executing gem ... (Gem::Exception)
    Unable to require openssl, install OpenSSL and rebuild ruby (preferred) or
use non-HTTPS sources

Signed-off-by: Nicolas Carrier <nicolas.carrier@orolia.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/ruby/ruby.mk

index c3d021c3818bb268fa771944eb39ff5b6a041104..1899d1479769907aeac12d17853ed503b7abf3a8 100644 (file)
@@ -10,12 +10,12 @@ RUBY_VERSION_EXT = 2.4.0
 RUBY_SITE = http://cache.ruby-lang.org/pub/ruby/$(RUBY_VERSION_MAJOR)
 RUBY_SOURCE = ruby-$(RUBY_VERSION).tar.xz
 RUBY_DEPENDENCIES = host-pkgconf host-ruby
-HOST_RUBY_DEPENDENCIES = host-pkgconf
+HOST_RUBY_DEPENDENCIES = host-pkgconf host-openssl
 RUBY_MAKE_ENV = $(TARGET_MAKE_ENV)
 RUBY_CONF_OPTS = --disable-install-doc --disable-rpath --disable-rubygems
 HOST_RUBY_CONF_OPTS = \
        --disable-install-doc \
-       --with-out-ext=curses,openssl,readline \
+       --with-out-ext=curses,readline \
        --without-gmp
 RUBY_LICENSE = Ruby or BSD-2-Clause, BSD-3-Clause, others
 RUBY_LICENSE_FILES = LEGAL COPYING BSDL