package/systemd: add repart support
authorJames Hilliard <james.hilliard1@gmail.com>
Sun, 8 Mar 2020 09:16:40 +0000 (03:16 -0600)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 8 Mar 2020 14:16:05 +0000 (15:16 +0100)
systemd-repart grows and adds partitions to a partition table, based on
the configuration files described in repart.d.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/systemd/Config.in
package/systemd/systemd.mk

index c727082a1a0987dcc86bae70d44a80e7be7a778f..6f5f5c3346232ea174ace431d300ccef3087dc18 100644 (file)
@@ -318,6 +318,16 @@ config BR2_PACKAGE_SYSTEMD_RANDOMSEED
 
          http://www.freedesktop.org/software/systemd/man/systemd-random-seed.service.html
 
+config BR2_PACKAGE_SYSTEMD_REPART
+       bool "enable repart support"
+       select BR2_PACKAGE_OPENSSL
+       select BR2_PACKAGE_UTIL_LINUX_LIBFDISK
+       help
+         systemd-repart grows and adds partitions to a partition table,
+         based on the configuration files described in repart.d.
+
+         https://www.freedesktop.org/software/systemd/man/systemd-repart.html
+
 config BR2_PACKAGE_SYSTEMD_RESOLVED
        bool "enable resolve daemon"
        default y
index d97336b7cde4c57aae2a11d2a110abf5e83aa25a..c7a253bbe4169cc6219801fa384f13dde3eccf96 100644 (file)
@@ -41,7 +41,6 @@ SYSTEMD_CONF_OPTS += \
        -Dumount-path=/usr/bin/umount \
        -Dnobody-group=nogroup \
        -Didn=true \
-       -Drepart=false \
        -Duserdb=false \
        -Dhomed=false \
        -Dnss-systemd=true
@@ -305,6 +304,13 @@ else
 SYSTEMD_CONF_OPTS += -Dlocaled=false
 endif
 
+ifeq ($(BR2_PACKAGE_SYSTEMD_REPART),y)
+SYSTEMD_CONF_OPTS += -Drepart=true
+SYSTEMD_DEPENDENCIES += openssl
+else
+SYSTEMD_CONF_OPTS += -Drepart=false
+endif
+
 ifeq ($(BR2_PACKAGE_SYSTEMD_COREDUMP),y)
 SYSTEMD_CONF_OPTS += -Dcoredump=true
 SYSTEMD_COREDUMP_USER = systemd-coredump -1 systemd-coredump -1 * /var/lib/systemd/coredump - - Core Dumper