Add new netperf package
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 18 Feb 2010 15:49:27 +0000 (12:49 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 25 Mar 2010 10:54:22 +0000 (11:54 +0100)
Closes #1105

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/Config.in
package/netperf/Config.in [new file with mode: 0644]
package/netperf/netperf.mk [new file with mode: 0644]

diff --git a/CHANGES b/CHANGES
index 533a8e629108b2a379229dcd5836780be71384b2..bd8d6585627d3451e7c1bc7e8e6cc023a49a6c73 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -5,7 +5,7 @@
 
        X.org updated to 7.5.
 
-       New packages: librsync, lmbench, squid
+       New packages: librsync, lmbench, netperf, squid
 
        Updated/fixed packages: busybox, dosfstools, e2fsprogs,
        freetype, iperf, less, libglib2, libpng, mdadm, memstat,
@@ -17,6 +17,7 @@
        #661: lmbench: new package
        #800: [PATCH] iperf update to 2.0.4
        #805: [PATCH] mdadm - version update
+       #1105: Add new netperf package
        #1111: Bump wget to 1.12 and migrate to Makefile.autotools.in
        #1117: Bump nano to 2.2.3 and migrate to Makefile.autotools.in
        #1123: Bump less to 436 and migrate to Makefile.autotools.in
index 30702649a5918e57f710214a13ad129e1010b1e4..dda3f672a02891401f9b18349f951d2759d4a455 100644 (file)
@@ -179,6 +179,7 @@ source "package/netcat/Config.in"
 source "package/netkitbase/Config.in"
 source "package/netkittelnet/Config.in"
 endif
+source "package/netperf/Config.in"
 source "package/netplug/Config.in"
 source "package/netsnmp/Config.in"
 source "package/netstat-nat/Config.in"
diff --git a/package/netperf/Config.in b/package/netperf/Config.in
new file mode 100644 (file)
index 0000000..2f36b1b
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_NETPERF
+       bool "netperf"
+       help
+         Network performance benchmark tool
+
+         http://www.netperf.org/
diff --git a/package/netperf/netperf.mk b/package/netperf/netperf.mk
new file mode 100644 (file)
index 0000000..d198eee
--- /dev/null
@@ -0,0 +1,25 @@
+#############################################################
+#
+# netperf
+#
+#############################################################
+
+NETPERF_VERSION = 2.4.5
+NETPERF_SITE = ftp://ftp.netperf.org/netperf
+NETPERF_CONF_ENV = ac_cv_func_setpgrp_void=set
+
+$(eval $(call AUTOTARGETS,package,netperf))
+
+$(NETPERF_TARGET_INSTALL_TARGET):
+       $(call MESSAGE,"Installing to target")
+       $(INSTALL) -m 0755 $(NETPERF_DIR)/src/netperf \
+               $(TARGET_DIR)/usr/bin/netperf
+       $(INSTALL) -m 0755 $(NETPERF_DIR)/src/netserver \
+               $(TARGET_DIR)/usr/bin/netserver
+       touch $@
+
+$(NETPERF_TARGET_UNINSTALL):
+       $(call MESSAGE,"Uninstalling")
+       rm -f $(TARGET_DIR)/usr/bin/netperf
+       rm -f $(TARGET_DIR)/usr/bin/netserver
+       rm -f $(NETPERF_TARGET_INSTALL_TARGET) $(NETPERF_HOOK_POST_INSTALL)