package/lua-cqueues: bump to version 20200726
authorFrancois Perrad <fperrad@gmail.com>
Mon, 10 Aug 2020 10:18:39 +0000 (12:18 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 12 Aug 2020 14:51:15 +0000 (16:51 +0200)
supports Lua 5.4

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/lua-cqueues/Config.in
package/lua-cqueues/lua-cqueues.hash
package/lua-cqueues/lua-cqueues.mk
package/lua-http/Config.in

index c319fbdf4dea51c40a2a14ce617a78129cac9a4d..60f022848bc57e2a31cf7d6a4aba9e4d5b63b47f 100644 (file)
@@ -1,7 +1,6 @@
 config BR2_PACKAGE_LUA_CQUEUES
        bool "lua-cqueues"
        depends on BR2_TOOLCHAIN_HAS_THREADS
-       depends on !BR2_PACKAGE_LUA_5_4
        select BR2_PACKAGE_OPENSSL
        help
          Continuation Queues: Embeddable asynchronous networking,
@@ -9,5 +8,5 @@ config BR2_PACKAGE_LUA_CQUEUES
 
          http://25thandclement.com/~william/projects/cqueues.html
 
-comment "lua-cqueues needs a toolchain w/ threads, Lua <= 5.3"
-       depends on !BR2_TOOLCHAIN_HAS_THREADS || BR2_PACKAGE_LUA_5_4
+comment "lua-cqueues needs a toolchain w/ threads"
+       depends on !BR2_TOOLCHAIN_HAS_THREADS
index e12cdc642cacb9e85c99eff8662b16b7966b236d..5803a60d5067196e1342bd09f23eee1be0b25032 100644 (file)
@@ -1,3 +1,3 @@
 # Locally calculated
-sha256  45b4a0105c096eee5840b69e8e0078eb7b5d61a23aeca30db710f1caac3ec399  lua-cqueues-20200603.tar.gz
+sha256  9e112edd246da5cfca264314b70325a0b63665cb87a00e45ee3ae4f194000d52  lua-cqueues-20200726.tar.gz
 sha256  5f4b1f94047790eadf8fd0f9a8e3bd2895bea4c9a2c0f8bf7cd8c8e57caa5219  LICENSE
index bfa1df7447c045885e0b7a2f8f013248ccea6120..6d842eca9724203c8b6d4bb794735315065808c8 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-LUA_CQUEUES_VERSION = 20200603
+LUA_CQUEUES_VERSION = 20200726
 LUA_CQUEUES_SITE = $(call github,wahern,cqueues,rel-$(LUA_CQUEUES_VERSION))
 LUA_CQUEUES_LICENSE = MIT
 LUA_CQUEUES_LICENSE_FILES = LICENSE
index 76eff7f299ee750e4f4462c16a8f17ccdc5e94f1..8eefd481b5c330b3ac3a2a0e7a9fc9f9ec12c219 100644 (file)
@@ -1,7 +1,6 @@
 config BR2_PACKAGE_LUA_HTTP
        bool "lua-http"
        depends on BR2_TOOLCHAIN_HAS_THREADS    # luaossl & lua-cqueues
-       depends on !BR2_PACKAGE_LUA_5_4 # lua-cqueues
        select BR2_PACKAGE_LPEG # runtime
        select BR2_PACKAGE_LUA_BASEXX # runtime
        select BR2_PACKAGE_LUA_BINARYHEAP # runtime
@@ -16,5 +15,5 @@ config BR2_PACKAGE_LUA_HTTP
 
          https://daurnimator.github.io/lua-http/
 
-comment "lua-http needs a toolchain w/ threads, Lua <= 5.3"
-       depends on !BR2_TOOLCHAIN_HAS_THREADS || BR2_PACKAGE_LUA_5_4
+comment "lua-http needs a toolchain w/ threads"
+       depends on !BR2_TOOLCHAIN_HAS_THREADS