python2: generate reproducible .pyc
authorJérôme Pouiller <jezz@sysmic.org>
Tue, 20 Dec 2016 13:46:23 +0000 (14:46 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 20 Mar 2017 22:03:15 +0000 (23:03 +0100)
.pyc files contain the modification time of the corresponding .py
source. In order to make the build reproducible, we fix the modification
time of all .py before compiling .pyc files.

In addition, since pycompile relies on the modification time to know if
a file needs to be recompiled, it is safer to force recompilation of all
source files.

This work was sponsored by `BA Robotic Systems'.

Signed-off-by: Jérôme Pouiller <jezz@sysmic.org>
Reviewed-by: Samuel Martin <s.martin49@gmail.com>
[Thomas: do not register PYTHON_FIX_TIME as a
 PYTHON_TARGET_FINALIZE_HOOKS, instead call it inside
 PYTHON_CREATE_PYC_FILES before doing the byte compilation.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-elecrons.com>
package/python/python.mk

index 8f4e298c4cc4eb77655844bb5e1bcdbe5c6a0825..17875761888ff2a5ad911f03c1c5becd26416532 100644 (file)
@@ -244,10 +244,18 @@ PYTHON_PATH = $(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/sysconfigdata/
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))
 
+ifeq ($(BR2_REPRODUCIBLE),y)
+define PYTHON_FIX_TIME
+       find $(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR) -name '*.py' -print0 | \
+               xargs -0 --no-run-if-empty touch -d @$(SOURCE_DATE_EPOCH)
+endef
+endif
+
 define PYTHON_CREATE_PYC_FILES
+       $(PYTHON_FIX_TIME)
        PYTHONPATH="$(PYTHON_PATH)" \
        $(HOST_DIR)/usr/bin/python$(PYTHON_VERSION_MAJOR) \
-               support/scripts/pycompile.py \
+               support/scripts/pycompile.py $(if $(BR2_REPRODUCIBLE),--force) \
                $(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)
 endef