samba: make installation of smbd configurable
authorSven Neumann <s.neumann@raumfeld.com>
Mon, 1 Aug 2011 21:46:16 +0000 (23:46 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 11 Sep 2011 20:46:46 +0000 (22:46 +0200)
It may be desirable to compile samba but not actually install
the smbd binary. This is the case if you need libsmbclient but
don't want to run a samba server.

Make this possible by allowing to disable installation of smbd.

Signed-off-by: Sven Neumann <s.neumann@raumfeld.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/samba/Config.in
package/samba/samba.mk

index 58a84f3d623f61ec9901bbe5618545818e4ac915..3a777766a8f536f66a9a1f4d592db336ad57989a 100644 (file)
@@ -122,6 +122,13 @@ config BR2_PACKAGE_SAMBA_SMBCQUOTAS
        help
          Set or get QUOTAs of NTFS 5 shares
 
+config BR2_PACKAGE_SAMBA_SMBD
+       bool "smbd"
+       default y
+       depends on BR2_PACKAGE_SAMBA
+       help
+         The server daemon that provides filesharing and printing services
+
 config BR2_PACKAGE_SAMBA_SMBGET
        bool "smbget"
        default y
index dfc7636846cf43db8045de39a7adb155dbbdfd5b..621d13c6aa87d8bcdde926b4896de1ef7848ef88 100644 (file)
@@ -111,6 +111,7 @@ SAMBA_BINTARGETS_$(BR2_PACKAGE_SAMBA_SMBCACLS) += usr/bin/smbcacls
 SAMBA_BINTARGETS_$(BR2_PACKAGE_SAMBA_SMBCLIENT) += usr/bin/smbclient
 SAMBA_BINTARGETS_$(BR2_PACKAGE_SAMBA_SMBCONTROL) += usr/bin/smbcontrol
 SAMBA_BINTARGETS_$(BR2_PACKAGE_SAMBA_SMBCQUOTAS) += usr/bin/smbcquotas
+SAMBA_BINTARGETS_$(BR2_PACKAGE_SAMBA_SMBD) += usr/sbin/smbd
 SAMBA_BINTARGETS_$(BR2_PACKAGE_SAMBA_SMBGET) += usr/bin/smbget
 SAMBA_BINTARGETS_$(BR2_PACKAGE_SAMBA_SMBLDBTOOLS) += usr/bin/ldbadd
 SAMBA_BINTARGETS_$(BR2_PACKAGE_SAMBA_SMBLDBTOOLS) += usr/bin/ldbdel