package/iptables: bear the kernel options munging
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 4 Apr 2020 12:10:30 +0000 (14:10 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 1 May 2020 13:50:29 +0000 (15:50 +0200)
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
linux/linux.mk
package/iptables/iptables.mk

index 8867be44f7b903f963a37412cc390bd09e6d0742..14dc78fc9eea4205fa3cfcc3c7d26d211c159c28 100644 (file)
@@ -357,11 +357,6 @@ define LINUX_KCONFIG_FIXUP_CMDS
                $(call KCONFIG_ENABLE_OPT,CONFIG_NET))
        $(if $(BR2_PACKAGE_LINUX_TOOLS_PERF),
                $(call KCONFIG_ENABLE_OPT,CONFIG_PERF_EVENTS))
-       $(if $(BR2_PACKAGE_IPTABLES),
-               $(call KCONFIG_ENABLE_OPT,CONFIG_IP_NF_IPTABLES)
-               $(call KCONFIG_ENABLE_OPT,CONFIG_IP_NF_FILTER)
-               $(call KCONFIG_ENABLE_OPT,CONFIG_NETFILTER)
-               $(call KCONFIG_ENABLE_OPT,CONFIG_NETFILTER_XTABLES))
        $(if $(BR2_PACKAGE_XTABLES_ADDONS),
                $(call KCONFIG_ENABLE_OPT,CONFIG_NETFILTER_ADVANCED)
                $(call KCONFIG_ENABLE_OPT,CONFIG_NF_CONNTRACK)
index ae5cf4ddd38e9e2bdd25143879d70d13e6ac0f85..7b964aaf41200655f566396b63b8c0b3d718a458 100644 (file)
@@ -47,4 +47,11 @@ else
 IPTABLES_CONF_OPTS += --disable-bpf-compiler --disable-nfsynproxy
 endif
 
+define IPTABLES_LINUX_CONFIG_FIXUPS
+       $(call KCONFIG_ENABLE_OPT,CONFIG_IP_NF_IPTABLES)
+       $(call KCONFIG_ENABLE_OPT,CONFIG_IP_NF_FILTER)
+       $(call KCONFIG_ENABLE_OPT,CONFIG_NETFILTER)
+       $(call KCONFIG_ENABLE_OPT,CONFIG_NETFILTER_XTABLES)
+endef
+
 $(eval $(autotools-package))