projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
7685dd4
)
php: only overwrite php.ini if not present in target_skeleton
author
Peter Korsgaard
<jacmet@sunsite.dk>
Wed, 4 Mar 2009 20:58:12 +0000
(20:58 -0000)
committer
Peter Korsgaard
<jacmet@sunsite.dk>
Wed, 4 Mar 2009 20:58:12 +0000
(20:58 -0000)
Allow platforms to provide a custom php.ini in their target_skeleton.
package/php/php.mk
patch
|
blob
|
history
diff --git
a/package/php/php.mk
b/package/php/php.mk
index 1f20039f872e7545bd850b98853543b48b70ff3c..ac8f9cdc2e17f886cebecb73638332fc31de4080 100644
(file)
--- a/
package/php/php.mk
+++ b/
package/php/php.mk
@@
-169,7
+169,8
@@
$(PHP_HOOK_POST_INSTALL):
rm -rf $(TARGET_DIR)/usr/lib/php
rm -f $(TARGET_DIR)/usr/bin/phpize
rm -f $(TARGET_DIR)/usr/bin/php-config
- $(INSTALL) -m 0755 $(BR2_PACKAGE_PHP_CONFIG) $(TARGET_DIR)/etc/php.ini
+ if [ ! -f $(TARGET_DIR)/etc/php.ini ]; then \
+ $(INSTALL) -m 0755 $(BR2_PACKAGE_PHP_CONFIG) $(TARGET_DIR)/etc/php.ini; fi
$(PHP_TARGET_UNINSTALL):
$(call MESSAGE,"Uninstalling")