unionfs: convert to cmake-package
authorArnout Vandecappelle <arnout@mind.be>
Sat, 13 Oct 2012 01:46:09 +0000 (01:46 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 13 Oct 2012 20:22:44 +0000 (22:22 +0200)
Fixes e.g. http://autobuild.buildroot.net/results/c279007dd8b89a1c6fc9b58d3c2cda01ab84279e

The addition of CPPFLAGS overrides the defines added in unionfs's
Makefile.  Since unionfs now has CMake support, use that instead.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/unionfs/unionfs.mk

index eb8109ecbbc36e81310bc64a92ee527c5d5090c5..6c86c57c3b730ce9334a139de39071774438468d 100644 (file)
@@ -11,12 +11,4 @@ UNIONFS_DEPENDENCIES = libfuse host-pkg-config
 UNIONFS_LICENSE = BSD-3c
 UNIONFS_LICENSE_FILES = LICENSE
 
-define UNIONFS_BUILD_CMDS
-       $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
-endef
-
-define UNIONFS_INSTALL_TARGET_CMDS
-       $(MAKE) -C $(@D) PREFIX=/usr DESTDIR=$(TARGET_DIR) install
-endef
-
-$(eval $(generic-package))
+$(eval $(cmake-package))