Fix GDB BFD test linking
authorPaulius Zaleckas <paulius.zaleckas@gmail.com>
Thu, 29 Apr 2010 19:19:20 +0000 (22:19 +0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 1 May 2010 20:53:41 +0000 (22:53 +0200)
When compiling GDB for target (in my case i386) it links
wrong BFD library from host OS. This prevents GDB from compiling
support for ELF and thus GDB is unusable on target.

More about this issue was already posted at:
http://lists.uclibc.org/pipermail/buildroot/2009-March/026585.html

Fix this issue by forcing ELF support.

Signed-off-by: Paulius Zaleckas <paulius.zaleckas@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/gdb/gdb.mk

index 5e91d981daecc592a6885ec73584dabbd2f8aef0..5725067c205c40952b38d5bcc01e69e4ec3f185c 100644 (file)
@@ -93,6 +93,8 @@ endif
        touch $@
 
 $(GDB_TARGET_DIR)/gdb/gdb: $(GDB_TARGET_DIR)/.configured
+       # force ELF support since it fails due to BFD linking problems
+       gdb_cv_var_elf=yes \
        $(MAKE) CC=$(TARGET_CC) MT_CFLAGS="$(TARGET_CFLAGS)" \
                -C $(GDB_TARGET_DIR)
        $(STRIPCMD) $(GDB_TARGET_DIR)/gdb/gdb