package/redis: add optional support for TLS connections
authorTitouan Christophe <titouan.christophe@railnova.eu>
Tue, 2 Jun 2020 10:40:10 +0000 (12:40 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Fri, 5 Jun 2020 22:26:31 +0000 (00:26 +0200)
TLS support is only enabled when BUILD_TLS is set to 'yes'. Anoy other
value, as well as empty or not set, will disable TLS. However, for
consistency with the rest of the code (e.g. for autotools packages where
we use both the --enable and --disable flags), we explcitly pass
BUILD_TLS=no. This also avoids an environment variable to leak into the
build.

Signed-off-by: Titouan Christophe <titouan.christophe@railnova.eu>
[yann.morin.1998@free.fr: add and explain the =no case]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/redis/redis.mk

index 1578f97e0d39fd48c15442c2071853da76c88227..ae823429b3cb7ade78d3e1275e6f0e1e002246bf 100644 (file)
@@ -30,6 +30,13 @@ endif
 REDIS_BUILDOPTS = $(TARGET_CONFIGURE_OPTS) \
        PREFIX=$(TARGET_DIR)/usr MALLOC=libc
 
+ifeq ($(BR2_PACKAGE_LIBOPENSSL),y)
+REDIS_DEPENDENCIES += libopenssl
+REDIS_BUILDOPTS += BUILD_TLS=yes
+else
+REDIS_BUILDOPTS += BUILD_TLS=no
+endif
+
 define REDIS_BUILD_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) $(REDIS_BUILDOPTS) -C $(@D)
 endef