mplayer: add license info
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 7 Oct 2015 20:15:54 +0000 (17:15 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 8 Oct 2015 15:08:45 +0000 (17:08 +0200)
Most code is GPLv2+ or compatible except for one file that is
GPLv2-only, hence as a whole is GPLv2 (see Copyright).
Also kill some whitespace and make the only hard dependency
(host-pkgconf) a hard dependency, not an addition, since it's not
conditional.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mplayer/mplayer.mk

index bab7ed75d3e0d1f14840fbf0e231c0e2496bfe7b..d896b350c1b9019262a826fe54ce7ea52ab0b250 100644 (file)
@@ -7,12 +7,12 @@
 MPLAYER_VERSION = 1.2
 MPLAYER_SOURCE = MPlayer-$(MPLAYER_VERSION).tar.xz
 MPLAYER_SITE = http://www.mplayerhq.hu/MPlayer/releases
-
+MPLAYER_DEPENDENCIES = host-pkgconf
+MPLAYER_LICENSE = GPLv2
+MPLAYER_LICENSE_FILES = LICENSE Copyright
 MPLAYER_CFLAGS = $(TARGET_CFLAGS)
 MPLAYER_LDFLAGS = $(TARGET_LDFLAGS)
 
-MPLAYER_DEPENDENCIES += host-pkgconf
-
 # mplayer needs pcm+mixer support, but configure fails to check for it
 ifeq ($(BR2_PACKAGE_ALSA_LIB)$(BR2_PACKAGE_ALSA_LIB_MIXER)$(BR2_PACKAGE_ALSA_LIB_PCM),yyy)
 MPLAYER_DEPENDENCIES += alsa-lib