linux: don't force no initramfs
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 12 Sep 2010 21:15:47 +0000 (23:15 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 15 Sep 2010 19:17:35 +0000 (21:17 +0200)
When initramfs was not selected as a root filesystem, we forcefully
disabled the initramfs in the kernel configuration.

However, it prevents an user from manually managing its initramfs, as
we override the option he has set in his kernel configuration
file. There's no real reason to do so: when initramfs is not selected
as the root filesystem, just don't touch initramfs related options in
the kernel configuration.

Problem reported by Sergey Naumov <sknaumov@gmail.com>.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
linux/linux.mk

index 3fc259c225d85b5f55855c033a0082d447fe450f..ea338fc5c581edd281f4500878bed3c644732b3b 100644 (file)
@@ -104,9 +104,6 @@ ifeq ($(BR2_TARGET_ROOTFS_INITRAMFS),y)
        $(call KCONFIG_ENABLE_OPT,CONFIG_BLK_DEV_INITRD,$(@D)/.config)
        $(call KCONFIG_SET_OPT,CONFIG_INITRAMFS_SOURCE,\"$(BINARIES_DIR)/rootfs.initramfs\",$(@D)/.config)
        $(call KCONFIG_ENABLE_OPT,CONFIG_INITRAMFS_COMPRESSION_GZIP,$(@D)/.config)
-else
-       $(call KCONFIG_DISABLE_OPT,CONFIG_BLK_DEV_INITRD,$(@D)/.config)
-       $(call KCONFIG_SET_OPT,CONFIG_INITRAMFS_SOURCE,\"\",$(@D)/.config)
 endif
        $(TARGET_MAKE_ENV) $(MAKE) $(LINUX26_MAKE_FLAGS) -C $(@D) oldconfig
        $(Q)touch $@