projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
df00b17
)
beecrypt: arm assembly optimizations needs ARM instructions support
author
Peter Korsgaard
<peter@korsgaard.com>
Mon, 27 Jun 2016 14:33:07 +0000
(16:33 +0200)
committer
Peter Korsgaard
<peter@korsgaard.com>
Mon, 27 Jun 2016 14:33:07 +0000
(16:33 +0200)
Fixes:
http://autobuild.buildroot.net/results/980/
98034ebb086987fb8fc004672164f609f5a69543
/
http://autobuild.buildroot.net/results/3bd/
3bdba5cf7e901f8600e567b1b0eb0866d6dfc523
/
So disable it for thumb(2)-only configurations (armv7m), similar to how we
do it for m68k coldfire.
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/beecrypt/beecrypt.mk
patch
|
blob
|
history
diff --git
a/package/beecrypt/beecrypt.mk
b/package/beecrypt/beecrypt.mk
index 4fcdf439a34a22383567d42e9f66f02906fc0782..bd29b3b2c8f7161a1a15c9db6a03950eeb8d5db6 100644
(file)
--- a/
package/beecrypt/beecrypt.mk
+++ b/
package/beecrypt/beecrypt.mk
@@
-22,6
+22,11
@@
ifeq ($(BR2_m68k_cf),y)
BEECRYPT_CONF_OPTS += --enable-debug
endif
+# arm asm optimization doesn't work for thumb-only
+ifeq ($(BR2_arm):$(BR2_ARM_CPU_HAS_ARM),y:)
+BEECRYPT_CONF_OPTS += --enable-debug
+endif
+
ifeq ($(BR2_PACKAGE_BEECRYPT_CPP),y)
BEECRYPT_DEPENDENCIES += icu
BEECRYPT_CONF_OPTS += --with-cplusplus