package/aubio: add libsamplerate optional dependency
authorRomain Naour <romain.naour@gmail.com>
Sat, 3 Dec 2016 12:17:36 +0000 (13:17 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 4 Dec 2016 15:22:09 +0000 (16:22 +0100)
Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/aubio/aubio.mk

index e1694ab64dbe60b819e38e1c0931225be4a5d417..ed00088a6af69efffb3cd42e47c6d3e247814026 100644 (file)
@@ -14,7 +14,6 @@ AUBIO_INSTALL_STAGING = YES
 AUBIO_CONF_OPTS = \
        --disable-docs \
        --disable-atlas \
-       --disable-samplerate \
        --disable-avcodec \
        --disable-jack \
        --disable-fftw3 \
@@ -27,4 +26,11 @@ else
 AUBIO_CONF_OPTS += --disable-sndfile
 endif
 
+ifeq ($(BR2_PACKAGE_LIBSAMPLERATE),y)
+AUBIO_DEPENDENCIES += libsamplerate
+AUBIO_CONF_OPTS += --enable-samplerate
+else
+AUBIO_CONF_OPTS += --disable-samplerate
+endif
+
 $(eval $(waf-package))