package/mesa3d-demos: bump to 8.4.0
authorRomain Naour <romain.naour@gmail.com>
Sat, 24 Feb 2018 11:12:14 +0000 (12:12 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 25 Feb 2018 21:06:46 +0000 (22:06 +0100)
Use the new upstream url.
Added all hashes provided by upstream.
Rebase patch on top of 8.4.0 and convert it to git formated patch.
Add a comment above "MESA3D_DEMOS_AUTORECONF = YES"

See https://lists.freedesktop.org/archives/mesa-dev/2018-February/186542.html

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/mesa3d-demos/0001-demos-makes-opengl-an-optional-component.patch [new file with mode: 0644]
package/mesa3d-demos/0001-demos-optional-gl.patch [deleted file]
package/mesa3d-demos/mesa3d-demos.hash
package/mesa3d-demos/mesa3d-demos.mk

diff --git a/package/mesa3d-demos/0001-demos-makes-opengl-an-optional-component.patch b/package/mesa3d-demos/0001-demos-makes-opengl-an-optional-component.patch
new file mode 100644 (file)
index 0000000..b328fca
--- /dev/null
@@ -0,0 +1,88 @@
+From bb0ffae7164d296d32da24fa5499534de259169a Mon Sep 17 00:00:00 2001
+From: Spenser Gilliland <spenser@gillilanding.com>
+Date: Sat, 24 Feb 2018 11:36:17 +0100
+Subject: [PATCH] demos: makes opengl an optional component
+
+Signed-off-by: Spenser Gilliland <spenser@gillilanding.com>
+[Romain: convert to git patch, rebase on 8.4.0]
+Signed-off-by: Romain Naour <romain.naour@gmail.com>
+---
+ configure.ac               | 12 +++++++++++-
+ src/egl/opengl/Makefile.am |  2 ++
+ src/util/Makefile.am       |  2 ++
+ 3 files changed, 15 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 0b5e9a76..24298c44 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -51,6 +51,14 @@ m4_ifndef([PKG_PROG_PKG_CONFIG],
+   ACLOCAL="aclocal -I/other/macro/dir" before running autoreconf.])])
+ PKG_PROG_PKG_CONFIG()
++AC_ARG_ENABLE([gl],
++    [AS_HELP_STRING([--enable-gl],
++        [enable GL library @<:@default=no@:>@])],
++    [gl_enabled="$enableval"],
++    [gl_enabled=auto])
++
++if test "x$gl_enabled" != "xno"; then
++
+ dnl Get the pkg-config definitions for libGL.  We include a fallback
+ dnl path for GL implementation that don't provide a .pc file
+ PKG_CHECK_MODULES(GL, [gl], [], [
+@@ -112,6 +120,8 @@ PKG_CHECK_MODULES(GLU, [glu], [],
+ DEMO_CFLAGS="$DEMO_CFLAGS $GLU_CFLAGS"
+ DEMO_LIBS="$DEMO_LIBS $GLU_LIBS"
++fi
++
+ AC_ARG_ENABLE([egl],
+     [AS_HELP_STRING([--enable-egl],
+         [enable EGL library @<:@default=auto@:>@])],
+@@ -302,7 +312,7 @@ AC_SUBST([MESA_GLAPI])
+ AC_SUBST([WAYLAND_CFLAGS])
+ AC_SUBST([WAYLAND_LIBS])
+-
++AM_CONDITIONAL(HAVE_GL, test "x$gl_enabled" = "xyes")
+ AM_CONDITIONAL(HAVE_EGL, test "x$egl_enabled" = "xyes")
+ AM_CONDITIONAL(HAVE_GLESV1, test "x$glesv1_enabled" = "xyes")
+ AM_CONDITIONAL(HAVE_GLESV2, test "x$glesv2_enabled" = "xyes")
+diff --git a/src/egl/opengl/Makefile.am b/src/egl/opengl/Makefile.am
+index 6d184ff6..219ab850 100644
+--- a/src/egl/opengl/Makefile.am
++++ b/src/egl/opengl/Makefile.am
+@@ -56,6 +56,7 @@ endif
+ endif
+ if HAVE_EGL
++if HAVE_GL
+ bin_PROGRAMS = \
+       eglinfo
+ noinst_PROGRAMS = \
+@@ -64,6 +65,7 @@ noinst_PROGRAMS = \
+       $(EGL_X11_DEMOS) \
+       $(EGL_WL_DEMOS)
+ endif
++endif
+ egltri_x11_SOURCES = egltri.c
+ eglgears_x11_SOURCES = eglgears.c
+diff --git a/src/util/Makefile.am b/src/util/Makefile.am
+index 759a293a..012b9c75 100644
+--- a/src/util/Makefile.am
++++ b/src/util/Makefile.am
+@@ -27,7 +27,9 @@ AM_CFLAGS = \
+ AM_LDFLAGS = \
+       $(DEMO_LIBS)
++if HAVE_GL
+ noinst_LTLIBRARIES = libutil.la
++endif
+ if HAVE_GLUT
+ AM_CFLAGS += \
+-- 
+2.14.3
+
diff --git a/package/mesa3d-demos/0001-demos-optional-gl.patch b/package/mesa3d-demos/0001-demos-optional-gl.patch
deleted file mode 100644 (file)
index 6470e9d..0000000
+++ /dev/null
@@ -1,74 +0,0 @@
-This patches makes opengl an optional component.
-
-Signed-off-by: Spenser Gilliland <spenser@gillilanding.com>
----
-Index: mesa3d-demos-8.1.0/configure.ac
-===================================================================
---- mesa3d-demos-8.1.0.orig/configure.ac
-+++ mesa3d-demos-8.1.0/configure.ac
-@@ -51,6 +51,14 @@
-   ACLOCAL="aclocal -I/other/macro/dir" before running autoreconf.])])
- PKG_PROG_PKG_CONFIG()
-+AC_ARG_ENABLE([gl],
-+    [AS_HELP_STRING([--enable-gl],
-+        [enable GL library @<:@default=no@:>@])],
-+    [gl_enabled="$enableval"],
-+    [gl_enabled=auto])
-+
-+if test "x$gl_enabled" != "xno"; then
-+
- dnl Get the pkg-config definitions for libGL.  We include a fallback
- dnl path for GL implementation that don't provide a .pc file
- PKG_CHECK_MODULES(GL, [gl], [], [
-@@ -113,6 +121,8 @@
- DEMO_CFLAGS="$DEMO_CFLAGS $GLU_CFLAGS"
- DEMO_LIBS="$DEMO_LIBS $GLU_LIBS"
-+fi
-+
- AC_ARG_ENABLE([egl],
-     [AS_HELP_STRING([--enable-egl],
-         [enable EGL library @<:@default=auto@:>@])],
-@@ -303,7 +313,7 @@
- AC_SUBST([WAYLAND_CFLAGS])
- AC_SUBST([WAYLAND_LIBS])
--
-+AM_CONDITIONAL(HAVE_GL, test "x$gl_enabled" = "xyes")
- AM_CONDITIONAL(HAVE_EGL, test "x$egl_enabled" = "xyes")
- AM_CONDITIONAL(HAVE_GLESV1, test "x$glesv1_enabled" = "xyes")
- AM_CONDITIONAL(HAVE_GLESV2, test "x$glesv2_enabled" = "xyes")
-Index: mesa3d-demos-8.1.0/src/egl/opengl/Makefile.am
-===================================================================
---- mesa3d-demos-8.1.0.orig/src/egl/opengl/Makefile.am
-+++ mesa3d-demos-8.1.0/src/egl/opengl/Makefile.am
-@@ -50,12 +50,14 @@
- endif
- if HAVE_EGL
-+if HAVE_GL
- noinst_PROGRAMS = \
-       eglinfo \
-       peglgears \
-       $(EGL_DRM_DEMOS) \
-       $(EGL_X11_DEMOS)
- endif
-+endif
- egltri_x11_SOURCES = egltri.c
- eglgears_x11_SOURCES = eglgears.c
-Index: mesa3d-demos-8.1.0/src/util/Makefile.am
-===================================================================
---- mesa3d-demos-8.1.0.orig/src/util/Makefile.am
-+++ mesa3d-demos-8.1.0/src/util/Makefile.am
-@@ -27,7 +27,9 @@ AM_CFLAGS = \
- AM_LDFLAGS = \
-       $(DEMO_LIBS)
-+if HAVE_GL
- noinst_LTLIBRARIES = libutil.la
-+endif
- if HAVE_GLUT
- AM_CFLAGS += \
index a50a3a1e0cbb69619ffc20e03bde20ced8b39d0c..8a771df2f823b9be97d095afab8c027196cb2af7 100644 (file)
@@ -1,2 +1,5 @@
-# From http://lists.freedesktop.org/archives/mesa-announce/2015-December/000191.html
-sha256 c173154bbd0d5fb53d732471984def42fb1b14ac85fcb834138fb9518b3e0bef        mesa-demos-8.3.0.tar.bz2
+# From https://lists.freedesktop.org/archives/mesa-dev/2018-February/186542.html
+md5  6b65a02622765522176d00f553086fa3  mesa-demos-8.4.0.tar.bz2
+sha1 57ba892e919fa22ce3db9f25e7331a6fa33c652c  mesa-demos-8.4.0.tar.bz2
+sha256 01e99c94a0184e63e796728af89bfac559795fb2a0d6f506fa900455ca5fff7d  mesa-demos-8.4.0.tar.bz2
+sha512 b72d03cad36e0535ff18dcfb222ec4200064b9264f6da51a6e5f03b0dd912abe188bc1d600b6698de3ce6f63b28d2ce01565886ca8e7079edc4967fbf2fb0957  mesa-demos-8.4.0.tar.bz2
index cbc15c3b696fc2a65a931693317b735cd0394bcb..52a1e2420a0844dcaf033ebe1be231921f12968c 100644 (file)
@@ -4,9 +4,10 @@
 #
 ################################################################################
 
-MESA3D_DEMOS_VERSION = 8.3.0
+MESA3D_DEMOS_VERSION = 8.4.0
 MESA3D_DEMOS_SOURCE = mesa-demos-$(MESA3D_DEMOS_VERSION).tar.bz2
-MESA3D_DEMOS_SITE = ftp://ftp.freedesktop.org/pub/mesa/demos/$(MESA3D_DEMOS_VERSION)
+MESA3D_DEMOS_SITE = ftp://ftp.freedesktop.org/pub/mesa/demos
+# 0001-demos-makes-opengl-an-optional-component.patch
 MESA3D_DEMOS_AUTORECONF = YES
 MESA3D_DEMOS_DEPENDENCIES = host-pkgconf
 MESA3D_DEMOS_LICENSE = MIT