package/wireshark: add optional spandsp dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 10 Mar 2019 11:31:53 +0000 (12:31 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 11 Mar 2019 21:22:17 +0000 (22:22 +0100)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/wireshark/wireshark.mk

index 5f04af1f29c76a75a584b97758a68b5014513a75..a917efb5f6be8260a3f2f97dc74666f4c5ea4630 100644 (file)
@@ -145,6 +145,13 @@ else
 WIRESHARK_CONF_OPTS += --without-snappy
 endif
 
+ifeq ($(BR2_PACKAGE_SPANDSP),y)
+WIRESHARK_CONF_OPTS += --with-spandsp
+WIRESHARK_DEPENDENCIES += spandsp
+else
+WIRESHARK_CONF_OPTS += --without-spandsp
+endif
+
 define WIRESHARK_REMOVE_DOCS
        find $(TARGET_DIR)/usr/share/wireshark -name '*.txt' -print0 \
                -o -name '*.html' -print0 | xargs -0 rm -f