package/pkg-generic.mk: don't set INSTALL_{TARGET, STAGING, IMAGES} for host packages
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 11 Apr 2020 08:12:27 +0000 (10:12 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 25 Apr 2020 12:56:59 +0000 (14:56 +0200)
By their very nature, host packages have no target, staging, or images
install steps; they have a single install step, that is always
performed.

As such, setting the corresponding _INSTALL_{TARGET,STAGING,IMAGES}
variables does not make sense for host packages.

However, people (and scripts) may get confused when they process the
output of printvars, e.g.:

    $ make printvars VARS=HOST_LIBTOOL_INSTALL_TARGET
    HOST_LIBTOOL_INSTALL_TARGET=YES

Only set those variables for target packages. There is no
corresponding variable for host packages, as they are always installed
(and only once).

Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Cc: Vadim Kochan <vadim4j@gmail.com>
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Cc: Arnout Vandecappelle <arnout@mind.be>
Cc: eeppeliteloop@gmail.com
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/pkg-generic.mk

index 7679c41556654b0d9145489b5441ab4831ef8b5c..8cd5a7ff6228a2e40a939667bdea63071c74361c 100644 (file)
@@ -706,10 +706,6 @@ $(2)_FINAL_RECURSIVE_RDEPENDENCIES = $$(sort \
        ) \
        $$($(2)_FINAL_RECURSIVE_RDEPENDENCIES__X))
 
-$(2)_INSTALL_STAGING           ?= NO
-$(2)_INSTALL_IMAGES            ?= NO
-$(2)_INSTALL_TARGET            ?= YES
-
 # define sub-target stamps
 $(2)_TARGET_INSTALL_TARGET =   $$($(2)_DIR)/.stamp_target_installed
 $(2)_TARGET_INSTALL_STAGING =  $$($(2)_DIR)/.stamp_staging_installed
@@ -770,6 +766,9 @@ $(1):                       $(1)-install
 ifeq ($$($(2)_TYPE),host)
 $(1)-install:          $(1)-install-host
 else
+$(2)_INSTALL_STAGING   ?= NO
+$(2)_INSTALL_IMAGES    ?= NO
+$(2)_INSTALL_TARGET    ?= YES
 $(1)-install:          $(1)-install-staging $(1)-install-target $(1)-install-images
 endif