Makefile: change order of dirs and dependencies
authorThomas De Schampheleire <patrickdepinguin+buildroot@gmail.com>
Wed, 8 Feb 2012 16:22:19 +0000 (17:22 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 9 Feb 2012 21:10:43 +0000 (22:10 +0100)
If during the dependencies step, a package needs to be downloaded, the
download directory already has to be present. If not, the file will be
downloaded under the name 'dl' instead of in the directory 'dl'.

This patch changes the order of dirs and dependencies in the world target to
fix this.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index 2b228f7c3a89a4d47905fe359a40cf7e03c1af5b..d3e861063c7cbd70562fdd5e03092bfdc2f850df 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -375,7 +375,7 @@ $(BUILD_DIR)/buildroot-config/auto.conf: $(CONFIG_DIR)/.config
 
 prepare: $(BUILD_DIR)/buildroot-config/auto.conf
 
-world: prepare dependencies dirs $(BASE_TARGETS) $(TARGETS_ALL)
+world: prepare dirs dependencies $(BASE_TARGETS) $(TARGETS_ALL)
 
 $(O)/toolchainfile.cmake:
        @echo -en "\