utils/scanpypi: use python3 explicitly
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 16 Feb 2021 21:45:12 +0000 (22:45 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 20 Feb 2021 16:42:46 +0000 (17:42 +0100)
scanpypi is python3 compatible. In addition, it executes the setup.py
of Python modules to extract the relevant information. Since these are
more and more commonly using python3 constructs, using "python" to run
scanpypi causes problems on systems that have python2 installed as
python, when trying to parse setup.py scripts with python3 constructs.

Fixes part of #13516.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
utils/scanpypi

index 51bc249f9e693ab8ef27a3ae70d4dd59c68ddebb..47c7c00c6000817ff5859e27b852d68f7b5fec1c 100755 (executable)
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
 """
 
 Utility for building Buildroot packages for existing PyPI packages