apr: fix size of pid_t
authorJulien Beraud <julien.beraud@spectracom.orolia.com>
Tue, 21 Mar 2017 13:23:56 +0000 (14:23 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 21 Mar 2017 21:55:28 +0000 (22:55 +0100)
pid_t is a signed 32bits integer on both 32bits and 64bits
architectures.
This fixes an issue with apache server which causes bad pid
to be written in PidFile

Signed-off-by: Julien Beraud <julien.beraud@spectracom.orolia.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/apr/apr.mk

index 361a79f99baf601e8471451cd0b2d971ffd2093d..f09f94368cf93429cce0f4b473b4b5e797563dd4 100644 (file)
@@ -22,6 +22,7 @@ APR_CONF_ENV = \
        apr_cv_mutex_robust_shared=no \
        apr_cv_tcp_nodelay_with_cork=yes \
        ac_cv_sizeof_struct_iovec=8 \
+       ac_cv_sizeof_pid_t=4 \
        ac_cv_struct_rlimit=yes \
        ac_cv_o_nonblock_inherited=no \
        apr_cv_mutex_recursive=yes