package/x11r7/xserver_xorg-server: remove non-evdev input drivers for kdrive
authorBernd Kuhls <bernd.kuhls@t-online.de>
Thu, 15 Apr 2021 06:52:42 +0000 (08:52 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Thu, 15 Apr 2021 21:34:32 +0000 (23:34 +0200)
Upstream removed support for non-evdev input drivers for kdrive:
https://cgit.freedesktop.org/xorg/xserver/commit/configure.ac?h=server-1.20-branch&id=e7b8b7b131d8283c96ed0aff4593ab41441b5d3b

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Config.in.legacy
package/x11r7/xserver_xorg-server/Config.in
package/x11r7/xserver_xorg-server/xserver_xorg-server.mk

index 1f62348f9bf7a6c4fe6cbeb58dda632b66330c59..d22dca9a53af7403a9b76e6c24b76ea32851a276 100644 (file)
@@ -146,6 +146,18 @@ endif
 
 comment "Legacy options removed in 2021.05"
 
+config BR2_PACKAGE_XSERVER_XORG_SERVER_KDRIVE_KBD
+       bool "KDrive/TinyX kbd input driver removed"
+       select BR2_LEGACY
+       help
+         The kbd input driver in KDrive was removed.
+
+config BR2_PACKAGE_XSERVER_XORG_SERVER_KDRIVE_MOUSE
+       bool "KDrive/TinyX mouse input driver removed"
+       select BR2_LEGACY
+       help
+         The mouse input driver in KDrive was removed.
+
 config BR2_PACKAGE_MESA3D_OSMESA_CLASSIC
        bool "mesa OSMesa (classic) option removed"
        select BR2_LEGACY
index 3bf5af89bee926af7abc530c23eb88774fc50be1..1b9adadb5c2d02d092ded9760b29c6ea1b5242aa 100644 (file)
@@ -90,18 +90,6 @@ config BR2_PACKAGE_XSERVER_XORG_SERVER_KDRIVE_EVDEV
          Xfbdev -keybd evdev,,device=/dev/input/eventX
                 -mouse evdev,,device=/dev/input/eventY
 
-config BR2_PACKAGE_XSERVER_XORG_SERVER_KDRIVE_KBD
-       bool "Enable KDrive/TinyX kbd input driver"
-       help
-         Enable kbd input driver in KDrive. It uses the console
-         keyboard as input device.
-
-config BR2_PACKAGE_XSERVER_XORG_SERVER_KDRIVE_MOUSE
-       bool "Enable KDrive/TinyX mouse input driver"
-       help
-         Enable mouse input driver in KDrive. It supports PS/2 mice
-         and serial port mice.
-
 endif
 
 comment "Optional Servers"
index 3fa77cd4f0768b498523bbc5afb848b65fccc74d..03f36f1b28cca45ab99c50f5a7c6f6e269757628 100644 (file)
@@ -105,18 +105,6 @@ else
 XSERVER_XORG_SERVER_CONF_OPTS += --disable-kdrive-evdev
 endif
 
-ifeq ($(BR2_PACKAGE_XSERVER_XORG_SERVER_KDRIVE_KBD),y)
-XSERVER_XORG_SERVER_CONF_OPTS += --enable-kdrive-kbd
-else
-XSERVER_XORG_SERVER_CONF_OPTS += --disable-kdrive-kbd
-endif
-
-ifeq ($(BR2_PACKAGE_XSERVER_XORG_SERVER_KDRIVE_MOUSE),y)
-XSERVER_XORG_SERVER_CONF_OPTS += --enable-kdrive-mouse
-else
-XSERVER_XORG_SERVER_CONF_OPTS += --disable-kdrive-mouse
-endif
-
 else # modular
 XSERVER_XORG_SERVER_CONF_OPTS += --disable-kdrive --disable-xfbdev
 endif