package/coremark-pro: disable parallel build
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 8 Apr 2021 16:54:06 +0000 (18:54 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Wed, 5 May 2021 20:10:10 +0000 (22:10 +0200)
Disable parallel build as it seems to be totally broken:

/bin/bash: line 0: cd: /home/buildroot/autobuild/instance-2/output-1/build/coremark-pro-1.1.2743/builds/linux64/gcc64/obj/bench/core: No such file or directory

/bin/sh: 1: cd: can't cd to /home/buildroot/autobuild/instance-1/output-1/build/coremark-pro-1.1.2743/builds/linux/gcc/obj/bench/fp/loops/SP

Fixes:
 - http://autobuild.buildroot.org/results/7ba5e209772af7037fc735ea174d3fc3eaf46f4b
 - http://autobuild.buildroot.org/results/32b51bb9eda7899b6cc331f10a860644bd6004fa

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/coremark-pro/coremark-pro.mk

index 515b8eafbda0185d2ddbc7a494be3857ccc44b45..e797f66840f1e73732548a6445e0c12d1066c9ed 100644 (file)
@@ -40,7 +40,7 @@ COREMARK_PRO_MAKE_OPTS += \
        EXE=
 
 define COREMARK_PRO_BUILD_CMDS
-       $(TARGET_MAKE_ENV) $(MAKE) CC="$(TARGET_CC)" LD="$(TARGET_CC)" -C $(@D) \
+       $(TARGET_MAKE_ENV) $(MAKE1) CC="$(TARGET_CC)" LD="$(TARGET_CC)" -C $(@D) \
                $(COREMARK_PRO_MAKE_OPTS) build
 endef