package/freescale-imx/firmware-imx: copy all (lp)ddr files unconditionaly
authorHeiko Thiery <heiko.thiery@gmail.com>
Fri, 10 Sep 2021 14:09:25 +0000 (16:09 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 11 Sep 2021 20:52:14 +0000 (22:52 +0200)
In mainline u-boot more and more imx8 boards are switched to binman
to create the imx specific image (flash.bin). To support this the
(lp)ddr firmware training files are needed. For this to work all files
should be made available to the U-Boot build.

Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
Reviewed-by: Gary Bisson <gary.bisson@boundarydevices.com>
Reviewed-by: Fabio Estevam <festevam@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/freescale-imx/firmware-imx/firmware-imx.mk

index 1076cf85f1be11eb8c44066aa68362915c9073bb..29241342be84942b4af0505a6aa2bac2dac28aca 100644 (file)
@@ -51,6 +51,11 @@ define FIRMWARE_IMX_INSTALL_IMAGE_DDR_FW
                $(FIRMWARE_IMX_DDRFW_DIR)/lpddr4_pmu_train_2d_fw.bin > \
                $(BINARIES_DIR)/lpddr4_pmu_train_fw.bin
        ln -sf $(BINARIES_DIR)/lpddr4_pmu_train_fw.bin $(BINARIES_DIR)/ddr_fw.bin
+
+       # U-Boot supports creation of the combined flash.bin image. To make
+       # sure that U-Boot can access all available files copy them to
+       # the binary dir.
+       cp $(FIRMWARE_IMX_DDRFW_DIR)/lpddr4*.bin $(BINARIES_DIR)/
 endef
 endif
 
@@ -69,6 +74,11 @@ define FIRMWARE_IMX_INSTALL_IMAGE_DDR_FW
                $(FIRMWARE_IMX_DDRFW_DIR)/ddr4_2d_201810_fw.bin > \
                $(BINARIES_DIR)/ddr4_201810_fw.bin
        ln -sf $(BINARIES_DIR)/ddr4_201810_fw.bin $(BINARIES_DIR)/ddr_fw.bin
+
+       # U-Boot supports creation of the combined flash.bin image. To make
+       # sure that U-Boot can access all available files copy them to
+       # the binary dir.
+       cp $(FIRMWARE_IMX_DDRFW_DIR)/ddr4*.bin $(BINARIES_DIR)/
 endef
 endif