python-thrift: new package
authorVinicius Tinti <viniciustinti@gmail.com>
Wed, 20 Mar 2013 23:59:20 +0000 (23:59 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 6 May 2013 22:33:14 +0000 (00:33 +0200)
Add Python bindings for the Apache Thrift RPC.

Thrift is an interface definition language that is used to define and create
services for numerous languages using remote procedure calls (RPC).

This patch does not include the Thrift code generator. It only includes the
Thrift libraries used at runtime.

Signed-off-by: Tiago Maluta <tiagomaluta@gmail.com>
Signed-off-by: Vinicius Tinti <viniciustinti@gmail.com>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/python-thrift/Config.in [new file with mode: 0644]
package/python-thrift/python-thrift.mk [new file with mode: 0644]

index 6b3824213906a9dbf4d5e1bdc8303b45ab881ee5..81a3f76e18e76e5b8fc088d4681e049e21b7b5f6 100644 (file)
@@ -341,6 +341,7 @@ source "package/python-pygame/Config.in"
 source "package/python-pyparsing/Config.in"
 source "package/python-serial/Config.in"
 source "package/python-setuptools/Config.in"
+source "package/python-thrift/Config.in"
 endmenu
 endif
 source "package/ruby/Config.in"
diff --git a/package/python-thrift/Config.in b/package/python-thrift/Config.in
new file mode 100644 (file)
index 0000000..94a7590
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_PYTHON_THRIFT
+       bool "python-thrift"
+       depends on BR2_PACKAGE_PYTHON
+       help
+         python-thrift is a Python bindings for the Apache Thrift RPC system.
+
+         http://thrift.apache.org/
diff --git a/package/python-thrift/python-thrift.mk b/package/python-thrift/python-thrift.mk
new file mode 100644 (file)
index 0000000..c2fc752
--- /dev/null
@@ -0,0 +1,30 @@
+#############################################################
+#
+# python-thrift
+#
+#############################################################
+
+PYTHON_THRIFT_VERSION = 0.9.0
+PYTHON_THRIFT_SOURCE = thrift-$(PYTHON_THRIFT_VERSION).tar.gz
+PYTHON_THRIFT_SITE = http://pypi.python.org/packages/source/t/thrift
+PYTHON_THRIFT_LICENSE = Apache-2.0
+PYTHON_THRIFT_LICENSE_FILES = README
+
+PYTHON_THRIFT_DEPENDENCIES = python
+
+define PYTHON_THRIFT_BUILD_CMDS
+       (cd $(@D); \
+               PYTHONXCPREFIX="$(STAGING_DIR)/usr/" \
+               LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
+               $(HOST_DIR)/usr/bin/python setup.py build)
+endef
+
+# host-distutilscross, if it has been installed before, will check that
+# the installation directory is in python's load path. For host-python,
+# it is not, so add it explicitly while installing to target.
+define PYTHON_THRIFT_INSTALL_TARGET_CMDS
+       (cd $(@D); PYTHONPATH=$(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages \
+               $(HOST_DIR)/usr/bin/python setup.py install --prefix=$(TARGET_DIR)/usr)
+endef
+
+$(eval $(generic-package))