ncftp: specify ln -sf to remove existing destination files
authorAxel Lin <axel.lin@ingics.com>
Mon, 14 Oct 2013 13:21:30 +0000 (21:21 +0800)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 14 Oct 2013 19:59:53 +0000 (21:59 +0200)
This fixes below build error when executing "make ncftp-dirclean; make".

ln -s /usr/bin/ncftpbatch /opt/test/br-x86/buildroot/output/target/usr/bin/ncftpspooler
ln: failed to create symbolic link '/opt/test/br-x86/buildroot/output/target/usr/bin/ncftpspooler': File exists
make: *** [/opt/test/br-x86/buildroot/output/build/ncftp-3.2.5/.stamp_target_installed] Error 1

Signed-off-by: Axel Lin <axel.lin@ingics.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ncftp/ncftp.mk

index 56d5d474e6d79ac5f4f50d6c305fb3938f973673..03874d1598e2e26683d0fdc8f80e278868655400 100644 (file)
@@ -26,7 +26,7 @@ endif
 ifeq ($(BR2_PACKAGE_NCFTP_BATCH),y)
        NCFTP_TARGET_BINS += ncftpbatch
        NCFTP_INSTALL_NCFTP_BATCH = \
-               ln -s /usr/bin/ncftpbatch $(TARGET_DIR)/usr/bin/ncftpspooler
+               ln -sf /usr/bin/ncftpbatch $(TARGET_DIR)/usr/bin/ncftpspooler
 endif
 
 ifeq ($(BR2_PACKAGE_NCFTP_BOOKMARKS),y)