qtuio: new package
authorStephan Hoffmann <sho@relinux.de>
Fri, 21 Sep 2012 20:59:49 +0000 (20:59 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 21 Oct 2012 19:48:10 +0000 (21:48 +0200)
Implementation of an interface connecting TUIO messages and QT events

https://github.com/x29a/qTUIO

Signed-off-by: Stephan Hoffmann <sho@relinux.de>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
 build-tested with a minimal internal toolchain for ARM.
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/qtuio/Config.in [new file with mode: 0644]
package/qtuio/qtuio.mk [new file with mode: 0644]

index 2ba68cf3d740112367e55baca54815934e72de0b..6842aab3820ee10ec5e2bf9010690abd646e7c7e 100644 (file)
@@ -134,6 +134,12 @@ source "package/sdl_gfx/Config.in"
 comment "other GUIs"
 source "package/efl/Config.in"
 source "package/qt/Config.in"
+
+if BR2_PACKAGE_QT
+comment "QT libraries and helper libraries"
+source "package/qtuio/Config.in"
+endif
+
 source "package/x11r7/Config.in"
 
 comment "X libraries and helper libraries"
diff --git a/package/qtuio/Config.in b/package/qtuio/Config.in
new file mode 100644 (file)
index 0000000..19499fd
--- /dev/null
@@ -0,0 +1,18 @@
+config BR2_PACKAGE_QTUIO
+       bool "qtuio"
+       depends on BR2_PACKAGE_QT_GUI_MODULE
+       help
+         Implementation of an interface connecting TUIO messages
+         and QT events
+
+         https://github.com/x29a/qTUIO
+
+config BR2_QTUIO_EXAMPLES
+       bool "qtuio examples"
+       depends on BR2_PACKAGE_QTUIO
+       help
+         Build and install qtuio examples
+
+comment "qtuio depends on QT gui module"
+       depends on !BR2_PACKAGE_QT_GUI_MODULE
+
diff --git a/package/qtuio/qtuio.mk b/package/qtuio/qtuio.mk
new file mode 100644 (file)
index 0000000..0ac8874
--- /dev/null
@@ -0,0 +1,69 @@
+#############################################################
+#
+# qTUIO
+#
+#############################################################
+QTUIO_VERSION = abe4973ff6
+QTUIO_SITE = git://github.com/x29a/qTUIO.git
+QTUIO_INSTALL_STAGING = YES
+QTUIO_DEPENDENCIES = qt
+
+QTUIO_LICENSE = GPLv3+
+QTUIO_LICENSE_FILES = COPYING
+
+# The pong example needs QtOpenGL support, which might become available
+# some time in the future. Then add pong to the list of examples.
+QTUIO_EXAMPLES = dials fingerpaint knobs pinchzoom
+
+ifeq ($(BR2_QTUIO_EXAMPLES),y)
+define QTUIO_CONFIGURE_EXAMPLES
+       for example in $(QTUIO_EXAMPLES) ; do \
+               (cd $(@D)/examples/$${example} && $(QT_QMAKE)) ; \
+       done
+endef
+endif
+
+define QTUIO_CONFIGURE_CMDS
+       cd $(@D)/src && $(QT_QMAKE)
+       $(QTUIO_CONFIGURE_EXAMPLES)
+endef
+
+ifeq ($(BR2_QTUIO_EXAMPLES),y)
+define QTUIO_BUILD_EXAMPLES
+       for example in $(QTUIO_EXAMPLES) ; do \
+               ($(MAKE) -C $(@D)/examples/$${example}) ; \
+       done
+endef
+endif
+
+define QTUIO_BUILD_CMDS
+       $(MAKE) -C $(@D)/src
+       $(QTUIO_BUILD_EXAMPLES)
+endef
+
+# Unfortunately, there is no working "install" target available
+ifeq ($(BR2_QTUIO_EXAMPLES),y)
+define QTUIO_INSTALL_EXAMPLES
+       for example in $(QTUIO_EXAMPLES) ; do \
+               ($(INSTALL) -D -m 0755 $(@D)/examples/$${example}/$${example} $(TARGET_DIR)/usr/share/qtuio/$${example}) ; \
+       done
+endef
+endif
+
+define QTUIO_INSTALL_TARGET_CMDS
+       cp -dpf $(@D)/lib/libqTUIO.so* $(TARGET_DIR)/usr/lib
+       $(QTUIO_INSTALL_EXAMPLES)
+endef
+
+define QTUIO_INSTALL_STAGING_CMDS
+       cp -dpf $(@D)/lib/libqTUIO.so* $(STAGING_DIR)/usr/lib
+endef
+
+define QTUIO_CLEAN_CMDS
+       $(MAKE) -C $(@D)/src clean
+       for example in $(QTUIO_EXAMPLES) ; do \
+               ($(MAKE) -C $(@D)/examples/$${example} clean) ; \
+       done
+endef
+
+$(eval $(generic-package))