Add support for custom post-build script
authorDaniel Mack <daniel@caiaq.de>
Wed, 8 Jul 2009 20:46:58 +0000 (22:46 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 25 Jul 2009 21:15:18 +0000 (23:15 +0200)
The config help text says it all:

  Specify a script to be run after the build has finished and before
  the BR2 starts packing the files into selected packages.

  This gives users the oportunity to do board-specific cleanups,
  add-ons and the like, so the generated files can be used directly
  without further processing.

  The script is called with the target directory name as first and
  only argument. Make sure the exit code of that script is 0,
  otherwise make will stop after calling it.

Signed-off-by: Daniel Mack <daniel@caiaq.de>
Cc: Sven Neumann <s.neumann@raumfeld.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile
target/Config.in

index f039f13d1f55b3695126aae913027a6d0fea6580..0fc538b6ac8a8bd0d708edbf285d89458c956452 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -363,6 +363,10 @@ endif
        find $(TARGET_DIR) -type f -perm +111 | xargs $(STRIPCMD) 2>/dev/null || true
        $(TARGET_LDCONFIG) -r $(TARGET_DIR) 2>/dev/null
 
+ifneq ($(BR2_ROOTFS_POST_BUILD_SCRIPT),"")
+       $(BR2_ROOTFS_POST_BUILD_SCRIPT) $(TARGET_DIR)
+endif
+
 ifeq ($(BR2_ENABLE_LOCALE_PURGE),y)
 LOCALE_WHITELIST=$(PROJECT_BUILD_DIR)/locales.nopurge
 LOCALE_NOPURGE=$(strip $(subst ",,$(BR2_ENABLE_LOCALE_WHITELIST)))
index a25581baadcf225ec4dbcad5a4f93c1559939f1a..ab46dcb162fcb972ebf7f3d488205ea30a44f38c 100644 (file)
@@ -12,6 +12,21 @@ config BR2_ROOTFS_SUFFIX
        help
          Add a custom string to the end of the root file system name.
 
+config BR2_ROOTFS_POST_BUILD_SCRIPT
+       string "Custom script to run before packing files"
+       default ""
+       help
+         Specify a script to be run after the build has finished and before
+         the BR2 starts packing the files into selected packages.
+
+         This gives users the oportunity to do board-specific cleanups,
+         add-ons and the like, so the generated files can be used directly
+         without further processing.
+
+         The script is called with the target directory name as first and
+         only argument. Make sure the exit code of that script is 0,
+         otherwise make will stop after calling it.
+
 comment "filesystem for target device"
 
 source "target/cramfs/Config.in"