package/janus-gateway: bump version to v0.1.0
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 5 Jun 2016 17:52:04 +0000 (19:52 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 5 Jun 2016 19:39:31 +0000 (21:39 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/janus-gateway/0001-disable-ssp.patch
package/janus-gateway/0002-Add-test-for-Wunused-but-set-variable.patch
package/janus-gateway/janus-gateway.mk

index 9ef184aa80ac35f43d0ae7e9d1085bffdcf92ebc..f03b58589b9ab7e4bbbf90066cb9160a1fa98472 100644 (file)
@@ -5,6 +5,8 @@ the package user pass the appropriate CFLAGS to enable SSP if needed.
 
 Signed-off-by: Gregory Dymarek <gregd72002@gmail.com>
 Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+(rebased against v0.1.0)
+Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
 
 diff -rupN janus-gateway-master.orig/Makefile.am janus-gateway-master/Makefile.am
 --- janus-gateway-master.orig/Makefile.am      2014-11-27 14:36:31.000000000 +0000
@@ -13,8 +15,8 @@ diff -rupN janus-gateway-master.orig/Makefile.am janus-gateway-master/Makefile.a
  # some fairly big refactoring though, which can wait.
  # AM_CFLAGS += -Wshadow -Wstrict-aliasing=2
  
--AM_CFLAGS += -fstack-protector-all -g -ggdb -fPIC -rdynamic
-+AM_CFLAGS += -g -ggdb -fPIC -rdynamic
+-AM_CFLAGS += -fstack-protector-all -g -ggdb -fPIC -rdynamic -pthread
++AM_CFLAGS += -g -ggdb -fPIC -rdynamic -pthread
  
  # FIXME: make docs work with distcheck
  DISTCHECK_CONFIGURE_FLAGS = --disable-docs --enable-post-processing
index 14acae55755a33a78d6cbe4d54a6a6773de0394d..13bc21ea42c17aae25d088059b55d66cc04c6a20 100644 (file)
@@ -14,6 +14,8 @@ and uses it to detect if the -Wunused-but-set-variable option is
 supported, and only uses it in this case.
 
 Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+(rebased against v0.1.0)
+Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
 ---
  Makefile.am                 |  2 +-
  configure.ac                |  3 ++
@@ -29,11 +31,11 @@ index 5d23e0b..0f51f6a 100644
        -Wnested-externs -Wstrict-prototypes -Wunsafe-loop-optimizations \
        -Wwrite-strings -Wno-missing-field-initializers -Wno-unused-parameter \
        -Wcast-align -Wformat-nonliteral -Wformat-security -Wswitch-default \
--      -Wmissing-include-dirs -Waggregate-return -Wunused-but-set-variable \
-+      -Wmissing-include-dirs -Waggregate-return @GCC_WARN_UNUSED_BUT_SET@ \
+-      -Wmissing-include-dirs -Wno-aggregate-return -Wunused-but-set-variable \
++      -Wmissing-include-dirs -Wno-aggregate-return @GCC_WARN_UNUSED_BUT_SET@ \
        -Warray-bounds -Wold-style-definition -Wsign-compare -Wlarger-than=65537
  AM_CFLAGS += -Wno-undef  # sophiasip is not -Wundef--safe
- AM_CFLAGS += -Wredundant-decls  # sophiasip also contains redundant declarations
+ AM_CFLAGS += -Wno-redundant-decls  # sophiasip also contains redundant declarations
 diff --git a/configure.ac b/configure.ac
 index 17870a7..f9bb1e4 100644
 --- a/configure.ac
index e1361d3dacc28d240a48f739c1ef4a391c95a10c..206a855cc89d0c4504e3c8f8789a800c55556dc0 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-JANUS_GATEWAY_VERSION = c632c1e9da5ffd8c34df6086a1aa5a8511a2a02d
+JANUS_GATEWAY_VERSION = v0.1.0
 JANUS_GATEWAY_SITE = $(call github,meetecho,janus-gateway,$(JANUS_GATEWAY_VERSION))
 JANUS_GATEWAY_LICENSE = GPLv3
 JANUS_GATEWAY_LICENSE_FILES = COPYING