wf111: fix overwriting module files during install
authorMatthew Starr <mstarr@hedonline.com>
Tue, 3 Nov 2015 16:52:13 +0000 (17:52 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 25 Apr 2016 21:47:49 +0000 (23:47 +0200)
When installing the WF111 modules, the module.* files generated during
the kernel compilation were overridden. This ended up having the wrong
information about the modules compiled in a given image (and only the
one about the WF111 module). This could be verified using the
"modprobe -l" command, with only the wf111 module showing up.

This patch fixes this by invoking the install_static target (which
will do both the build and installation) in WF111_INSTALL_TARGET_CMDS.
This way the files are not overridden but instead updated with the
additional WF111 informations.

Signed-off-by: Antoine Tenart <antoine.tenart@free-electrons.com>
Tested-by: Antoine Tenart <antoine.tenart@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/wf111/wf111.mk

index 479d665760b1506aa18135fa36cb4321c8deac80..28b181512a975808cf515b367bf0eb676890fdaa 100644 (file)
@@ -21,14 +21,13 @@ else ifeq ($(BR2_i386),y)
 WF111_SOURCE = wf111-linux-driver_5.2.2-r1_x86.tar.gz
 endif
 
-define WF111_BUILD_CMDS
+# Due to the stupidity of the package Makefile, we can't invoke
+# separately the build step and the install step and get a correct
+# behavior. So we do everything in the install step.
+define WF111_INSTALL_TARGET_CMDS
        $(MAKE) -C $(@D) PWD=$(@D) \
                $(LINUX_MAKE_FLAGS) KDIR=$(LINUX_DIR) \
-               install_static
-endef
-
-define WF111_INSTALL_TARGET_CMDS
-       cp -dpfr $(@D)/output/* $(TARGET_DIR)
+               OUTPUT=$(TARGET_DIR) install_static
 endef
 
 $(eval $(generic-package))