package/keyutils: fix build without C++
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 1 Oct 2020 06:46:13 +0000 (08:46 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 1 Oct 2020 08:49:46 +0000 (10:49 +0200)
Create cxx.stamp to disable the check that keyutils.h has a valid C++
syntax that has been added with
https://git.kernel.org/pub/scm/linux/kernel/git/dhowells/keyutils.git/commit/?id=991c272062a4300bbd5fe22dce17ab2fb5126e3f

Fixes:
 - http://autobuild.buildroot.org/results/53ec9ca02798a88cd9ab773af10fc8f44ce9d1a2

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/keyutils/keyutils.mk

index 46f06531cecd7d2d5f23fd3e5767363c836cc04f..cba57cf199e29c65d7177b055c23c5343cfa5469 100644 (file)
@@ -22,6 +22,11 @@ ifeq ($(BR2_SHARED_LIBS),y)
 KEYUTILS_MAKE_PARAMS += NO_ARLIB=1
 endif
 
+# Touch cxx.stamp to avoid adding a C++ dependency
+define KEYUTILS_CONFIGURE_CMDS
+       touch $(@D)/cxx.stamp
+endef
+
 define KEYUTILS_BUILD_CMDS
        $(TARGET_CONFIGURE_OPTS) $(MAKE) $(KEYUTILS_MAKE_PARAMS) -C $(@D)
 endef