linux: handle new dtb location since 3.8-rc1
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 21 Dec 2012 08:07:45 +0000 (09:07 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 21 Dec 2012 08:07:45 +0000 (09:07 +0100)
.dtb files are now generated in arch/$ARCH/boot/dts instead of
arch/$ARCH/boot, so extend the LINUX_INSTALL_DTB rule to look there
as well.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
linux/linux.mk

index 6586e68158c3340b76362dd297b615300ceecd2a..e852f626f228bb480b98d5e443e710d45d383624 100644 (file)
@@ -192,7 +192,10 @@ define LINUX_BUILD_DTB
        $(TARGET_MAKE_ENV) $(MAKE) $(LINUX_MAKE_FLAGS) -C $(@D) $(KERNEL_DTBS)
 endef
 define LINUX_INSTALL_DTB
-       cp $(addprefix $(KERNEL_ARCH_PATH)/boot/,$(KERNEL_DTBS)) \
+       # dtbs moved from arch/$ARCH/boot to arch/$ARCH/boot/dts since 3.8-rc1
+       cp $(addprefix \
+               $(KERNEL_ARCH_PATH)/boot/$(if $(wildcard \
+               $(addprefix $(KERNEL_ARCH_PATH)/boot/dts/,$(KERNEL_DTBS))),dts/),$(KERNEL_DTBS)) \
                $(BINARIES_DIR)/
 endef
 endif