package/kodi: optimise for RPi2
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 10 Apr 2016 16:22:06 +0000 (18:22 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 13 Apr 2016 21:12:52 +0000 (23:12 +0200)
Kodi has specific optimisation and configuration flags for RPi vs. RPi2.
Only configure for the RPi2 when we're sure (i.e. it is a cortex A7),
and fallback to con figuring for the RPi otherwise.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/kodi/kodi.mk

index 94a8cd8a62125a368aa1aacd2291087cef3d0ba2..ca1cae2ad071caef979f94a13c7930eca2edd365 100644 (file)
@@ -47,7 +47,14 @@ endif
 
 ifeq ($(BR2_PACKAGE_RPI_USERLAND),y)
 KODI_DEPENDENCIES += rpi-userland
-KODI_CONF_OPTS += --with-platform=raspberry-pi --enable-player=omxplayer
+# Kodi has specific configuration flags for RPi/RPi2. Configure for a
+# RPi2 when we're sure, fallback to RPi otherwise.
+ifeq ($(BR2_cortex_a7),y)
+KODI_CONF_OPTS += --with-platform=raspberry-pi2
+else
+KODI_CONF_OPTS += --with-platform=raspberry-pi
+endif
+KODI_CONF_OPTS += --enable-player=omxplayer
 KODI_CONF_ENV += INCLUDES="-I$(STAGING_DIR)/usr/include/interface/vcos/pthreads \
        -I$(STAGING_DIR)/usr/include/interface/vmcs_host/linux" \
        LIBS="-lvcos -lvchostif"