cdrkit: bump to version 1.1.11 and adjust style
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 14 Dec 2011 15:15:18 +0000 (12:15 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 21 Dec 2011 22:02:31 +0000 (23:02 +0100)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/cdrkit/cdrkit-1.1.10-no-rcmd.patch [deleted file]
package/cdrkit/cdrkit-1.1.11-no-rcmd.patch [new file with mode: 0644]
package/cdrkit/cdrkit.mk

diff --git a/package/cdrkit/cdrkit-1.1.10-no-rcmd.patch b/package/cdrkit/cdrkit-1.1.10-no-rcmd.patch
deleted file mode 100644 (file)
index 294779f..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-[PATCH] fix build with uClibc
-
-cdrkit unconditionally enables code using rcmd(3), which isn't available
-on uClibc.
-
-Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
----
- include/xconfig.h.in |    1 -
- 1 file changed, 1 deletion(-)
-
-Index: cdrkit-1.1.10/include/xconfig.h.in
-===================================================================
---- cdrkit-1.1.10.orig/include/xconfig.h.in
-+++ cdrkit-1.1.10/include/xconfig.h.in
-@@ -187,7 +187,6 @@
-  *    they are placed before the large file tests.
-  */
--#define HAVE_RCMD 1           /* rcmd() is present in libc/libsocket */
- #define HAVE_SOCKET 1         /* socket() is present in libc/libsocket */
- #define HAVE_SOCKETPAIR 1             /* socketpair() is present in libc/libsocket */
- #define HAVE_GETSERVBYNAME 1  /* getservbyname() is present in libc/libsocket */
diff --git a/package/cdrkit/cdrkit-1.1.11-no-rcmd.patch b/package/cdrkit/cdrkit-1.1.11-no-rcmd.patch
new file mode 100644 (file)
index 0000000..294779f
--- /dev/null
@@ -0,0 +1,22 @@
+[PATCH] fix build with uClibc
+
+cdrkit unconditionally enables code using rcmd(3), which isn't available
+on uClibc.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ include/xconfig.h.in |    1 -
+ 1 file changed, 1 deletion(-)
+
+Index: cdrkit-1.1.10/include/xconfig.h.in
+===================================================================
+--- cdrkit-1.1.10.orig/include/xconfig.h.in
++++ cdrkit-1.1.10/include/xconfig.h.in
+@@ -187,7 +187,6 @@
+  *    they are placed before the large file tests.
+  */
+-#define HAVE_RCMD 1           /* rcmd() is present in libc/libsocket */
+ #define HAVE_SOCKET 1         /* socket() is present in libc/libsocket */
+ #define HAVE_SOCKETPAIR 1             /* socketpair() is present in libc/libsocket */
+ #define HAVE_GETSERVBYNAME 1  /* getservbyname() is present in libc/libsocket */
index 9eebe6e075f1fcac8e21af080e9fcc49fde7b42f..fc22c18865877b07b799d8f44b55628905d89f23 100644 (file)
@@ -1,9 +1,13 @@
-CDRKIT_VERSION=1.1.10
-CDRKIT_SOURCE=cdrkit-$(CDRKIT_VERSION).tar.gz
-CDRKIT_SITE=http://www.cdrkit.org/releases/
+#############################################################
+#
+# cdrkit
+#
+#############################################################
 
-CDRKIT_DEPENDENCIES=libcap bzip2 zlib
-HOST_CDRKIT_DEPENDENCIES=host-libcap host-bzip2 host-zlib
+CDRKIT_VERSION = 1.1.11
+CDRKIT_SITE = http://www.cdrkit.org/releases
+CDRKIT_DEPENDENCIES = libcap bzip2 zlib
+HOST_CDRKIT_DEPENDENCIES = host-libcap host-bzip2 host-zlib
 
 ifeq ($(BR2_ENDIAN),"BIG")
 CMAKE_ENDIAN_OPT=-DBITFIELDS_HTOL=1