coreutils: fix build failure for musl
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 7 Nov 2014 12:45:46 +0000 (09:45 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 7 Nov 2014 13:33:02 +0000 (14:33 +0100)
musl doesn't implement re_match and friends and coreutils fails to
detect this properly, so force internal regex routines for musl.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/coreutils/coreutils.mk

index 41857e2ec4698049fa2036f7e4f83fa95dd0a7c9..391d2cd4071995ce9b3b4852d3d894d33cf858c7 100644 (file)
@@ -14,7 +14,8 @@ COREUTILS_LICENSE_FILES = COPYING
 COREUTILS_AUTORECONF = YES
 COREUTILS_GETTEXTIZE = YES
 
-COREUTILS_CONF_OPTS = --disable-rpath --enable-single-binary=shebangs
+COREUTILS_CONF_OPTS = --disable-rpath --enable-single-binary=shebangs \
+       $(if $(BR2_TOOLCHAIN_USES_MUSL),--with-included-regex)
 COREUTILS_CONF_ENV = ac_cv_c_restrict=no \
        ac_cv_func_chown_works=yes \
        ac_cv_func_euidaccess=no \