package/amd-catalyst: remove control center option
authorPeter Korsgaard <peter@korsgaard.com>
Wed, 6 Feb 2019 14:10:47 +0000 (15:10 +0100)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Wed, 6 Feb 2019 14:40:59 +0000 (15:40 +0100)
The control center option uses the obsolete qt4 package, which we are about
to remove, so remote the cccle option as well.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Config.in.legacy
package/amd-catalyst/Config.in
package/amd-catalyst/amd-catalyst.mk

index 0eb69361cc84a08592da43e214bc8c073d6c1319..dbd7450741dca40ab20171369683f2c9471a59a6 100644 (file)
@@ -146,6 +146,12 @@ endif
 
 comment "Legacy options removed in 2019.02"
 
+config BR2_PACKAGE_AMD_CATALYST_CCCLE
+       bool "catalyst control center option removed"
+       select BR2_LEGACY
+       help
+         The AMD Catalyst Control Center option was removed.
+
 config BR2_PACKAGE_SDL_QTOPIA
        bool "sdl qtopia video driver option removed"
        select BR2_LEGACY
index 85551ed8033b888e1b033e77aa5883d3bad5b02e..1a5bf02953efdf08a89c645745a85e4aac17ac64 100644 (file)
@@ -45,22 +45,6 @@ config BR2_PACKAGE_AMD_CATALYST_CMDLINE_TOOLS
        help
          Build and install the AMD command line tools.
 
-comment "Catalyst Control Center needs Qt4 with X11 and PNG support"
-       depends on !BR2_PACKAGE_QT || !BR2_PACKAGE_QT_X11 \
-               || BR2_PACKAGE_QT_NOPNG
-
-config BR2_PACKAGE_AMD_CATALYST_CCCLE
-       bool "Catalyst Control Center"
-       depends on BR2_PACKAGE_QT
-       depends on BR2_PACKAGE_QT_X11
-       depends on !BR2_PACKAGE_QT_NOPNG
-       select BR2_PACKAGE_BUSYBOX_SHOW_OTHERS # procps-ng
-       select BR2_PACKAGE_PROCPS_NG # runtime
-       select BR2_PACKAGE_QT_ACCESSIBILITY
-       help
-         Installs the Catalyst Control Center, a Qt graphical tool to
-         control AMD graphics accelerators.
-
 endif
 
 comment "amd-catalyst kernel module needs a kernel to be built"
index d864095c3173dcd7c3b761929efca523f0ede920..fe8aa850f0ef1a23fdad4042c199fc8aa349a1b8 100644 (file)
@@ -149,15 +149,6 @@ define  AMD_CATALYST_INSTALL_CMDLINE_TOOLS
 endef
 endif
 
-ifeq ($(BR2_PACKAGE_AMD_CATALYST_CCCLE), y)
-define AMD_CATALYST_INSTALL_CCCLE
-       $(INSTALL) -m 0755 $(AMD_CATALYST_ARCH_DIR)/usr/X11R6/bin/amdcccle \
-               $(TARGET_DIR)/usr/bin/amdcccle
-       $(INSTALL) -m 0755 $(AMD_CATALYST_ARCH_DIR)/usr/sbin/amdnotifyui \
-               $(TARGET_DIR)/usr/sbin/amdnotifyui
-endef
-endif
-
 define AMD_CATALYST_INSTALL_STAGING_CMDS
        $(call AMD_CATALYST_INSTALL_STAGING_XORG)
 endef
@@ -165,7 +156,6 @@ endef
 define AMD_CATALYST_INSTALL_TARGET_CMDS
        $(call AMD_CATALYST_INSTALL_XORG)
        $(call AMD_CATALYST_INSTALL_CMDLINE_TOOLS)
-       $(call AMD_CATALYST_INSTALL_CCCLE)
        $(call AMD_CATALYST_INSTALL_OPENCL)
 endef