qtopia4: fix wrong compilation of qmake
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 29 Oct 2008 20:40:51 +0000 (20:40 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 29 Oct 2008 20:40:51 +0000 (20:40 -0000)
Signed-off-by: Markus Heidelberg <markus.heidelberg@web.de>
package/qtopia4/qtopia4.mk

index c0ced9bc4833e3a7b1618335bf3a26f54d5cd997..9c08be92741c67edeee619d04e10f0868eb34e90 100644 (file)
@@ -257,8 +257,12 @@ endif
 # Qt doesn't use PKG_CONFIG, it searches for pkg-config with 'which'.
 # PKG_CONFIG_SYSROOT is only used to avoid a warning from Qt's configure system
 # when cross compiling, Qt 4.4.3 is wrong here.
+# Don't use TARGET_CONFIGURE_OPTS here, qmake would be compiled for the target
+# instead of the host then.
        (cd $(QTOPIA4_TARGET_DIR); rm -rf config.cache; \
-               $(TARGET_CONFIGURE_OPTS) \
+               PATH=$(TARGET_PATH) \
+               PKG_CONFIG_SYSROOT_DIR="$(STAGING_DIR)" \
+               PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig:$(PKG_CONFIG_PATH)" \
                PKG_CONFIG_SYSROOT="$(STAGING_DIR)" \
                ./configure \
                -verbose \