support/download: relocate the git clone comment
authorBaruch Siach <baruch@tkos.co.il>
Thu, 28 May 2015 11:35:28 +0000 (14:35 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 31 May 2015 09:56:56 +0000 (11:56 +0200)
Following commit 95a572282e87 (pkg-infra: move the git download helper to a
script, 2014-07-02), move the comment describing the shallow clone trickery as
well. Merge this comment with the existing helper comment that was added in
7e40a1103a91 (support/download: convert git to use the wrapper, 2014-08-03).

Rename $($(PKG)_DL_VERSION) to ${cset} to match the helper code context.

Cc: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pkg-download.mk
support/download/git

index f6ed8be567818b9c5c268b6c1bb82fa02d2e3806..c86b9abcff75a40d355012f91e25cec7eb7c0fa6 100644 (file)
@@ -73,12 +73,6 @@ export BR_NO_CHECK_HASH_FOR =
 # to get all the sources needed for one's build configuration.
 ################################################################################
 
-# Try a shallow clone - but that only works if the version is a ref (tag or
-# branch). Before trying to do a shallow clone we check if $($(PKG)_DL_VERSION)
-# is in the list provided by git ls-remote. If not we fall back on a full clone.
-#
-# Messages for the type of clone used are provided to ease debugging in case of
-# problems
 define DOWNLOAD_GIT
        $(EXTRA_ENV) $(DL_WRAPPER) -b git \
                -o $(DL_DIR)/$($(PKG)_SOURCE) \
index 73cbc0f7d173e3682c5221b194419b53b6a8b41a..fd5f5392ddec9387aa3b6f92ba4a2dd72edf7e73 100755 (executable)
@@ -25,8 +25,13 @@ repo="${2}"
 cset="${3}"
 basename="${4}"
 
-# Try to see if we can do a shallow clone, since it is faster
-# than a full clone.
+# Try a shallow clone, since it is faster than a full clone - but that only
+# works if the version is a ref (tag or branch). Before trying to do a shallow
+# clone we check if ${cset} is in the list provided by git ls-remote. If not
+# we fall back on a full clone.
+#
+# Messages for the type of clone used are provided to ease debugging in case of
+# problems
 git_done=0
 if [ -n "$(${GIT} ls-remote "${repo}" "${cset}" 2>&1)" ]; then
     printf "Doing shallow clone\n"