package/pure-ftpd: Add uploadscript option
authorSam Voss <sam.voss@rockwellcollins.com>
Fri, 12 Jan 2018 19:53:45 +0000 (13:53 -0600)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 28 Jan 2018 16:20:04 +0000 (17:20 +0100)
Enable option to compile with '--with-uploadscript' to allow running
script after successful uploads.

Signed-off-by: Sam Voss <sam.voss@rockwellcollins.com>
Acked-by: Bryce Ferguson <bryce.ferguson@rockwellcollins.com
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pure-ftpd/Config.in
package/pure-ftpd/pure-ftpd.mk

index b5eca876d9cd132434b9516655b1d5d543cf4a16..d03170b7cf7caaf6b6902ff33f60519358c70b93 100644 (file)
@@ -30,4 +30,10 @@ config BR2_PACKAGE_PURE_FTPD_QUOTAS
          his account. In addition, restrictions can also be placed on
          the total size.
 
+config BR2_PACKAGE_PURE_FTPD_UPLOADSCRIPT
+       bool "uploadscript"
+       help
+         Enable pure-upload script. Automatically run an external program
+         after a successful upload.
+
 endif
index 815de90f3bfe9b8a5ac9d1f246069ab31c86563e..457e67ea60649633b9ba258887e323909fb303d0 100644 (file)
@@ -53,4 +53,8 @@ ifeq ($(BR2_PACKAGE_PURE_FTPD_QUOTAS),y)
 PURE_FTPD_CONF_OPTS += --with-quotas
 endif
 
+ifeq ($(BR2_PACKAGE_PURE_FTPD_UPLOADSCRIPT),y)
+PURE_FTPD_CONF_OPTS += --with-uploadscript
+endif
+
 $(eval $(autotools-package))