coreutils: optimize the '[' symlink
authorBaruch Siach <baruch@tkos.co.il>
Wed, 11 Jul 2018 19:51:19 +0000 (22:51 +0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 16 Jul 2018 14:41:22 +0000 (16:41 +0200)
Link '[' directly to the coreutils binary instead of going through
'test'.

Suggested-by: Arnout Vandecappelle <arnout@mind.be>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/coreutils/coreutils.mk

index 2fb4a32c794ff6b1eb4715c29849e50f23845baf..7e7251ff7396399c6e2ab0005b9f3c325cccf5cc 100644 (file)
@@ -112,7 +112,7 @@ endif
 
 define COREUTILS_CLEANUP
        # link for archaic shells
-       ln -fs test $(TARGET_DIR)/usr/bin/[
+       ln -fs coreutils $(TARGET_DIR)/usr/bin/[
        # gnu thinks chroot is in bin, debian thinks it's in sbin
        rm -f $(TARGET_DIR)/usr/bin/chroot
        ln -sf ../bin/coreutils $(TARGET_DIR)/usr/sbin/chroot