package/libxml-parser-perl: make host build use correct compiler
authorNorbert Lange <nolange79@gmail.com>
Sat, 6 Jun 2020 22:23:38 +0000 (00:23 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 7 Sep 2020 21:54:14 +0000 (23:54 +0200)
This package uses gcc filename without absolute path, which breaks
the host build if host and target compiler have the same filename.
(Can happen with an external toolchain).

This patch adds the variables for the host as overrides,
as they are otherwise not picked up from the environment.

Signed-off-by: Norbert Lange <nolange79@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libxml-parser-perl/libxml-parser-perl.mk

index fcde5fc9390a81261c8ce2e3a2c55187492834a8..100c49633c521e7c30c38ea89675db3063d5691f 100644 (file)
@@ -25,7 +25,7 @@ define HOST_LIBXML_PARSER_PERL_CONFIGURE_CMDS
 endef
 
 define HOST_LIBXML_PARSER_PERL_BUILD_CMDS
-       $(HOST_MAKE_ENV) $(MAKE) -C $(@D)
+       $(HOST_MAKE_ENV) $(MAKE) $(HOST_CONFIGURE_OPTS) -C $(@D)
 endef
 
 define HOST_LIBXML_PARSER_PERL_INSTALL_CMDS