package/pkg-meson: allow meson packages to specify custom build rules
authorYann E. MORIN <yann.morin.1998@free.fr>
Wed, 26 Dec 2018 08:52:28 +0000 (09:52 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 28 Dec 2018 10:54:04 +0000 (11:54 +0100)
Some packages may want to build only specific targets, instead of the
default.

So, allow them to provide FOO_NINJA_OPTS (not really options, but we
just mimicked the naming we already have for autotools packages).

Update the manual accordingly.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Eric Le Bihan <eric.le.bihan.dev@free.fr>
Cc: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
docs/manual/adding-packages-meson.txt
package/pkg-meson.mk

index c52fe10506a6a876ae8e3819707a3d89921ce479..549319b192a09f8649005691391e5006747541ce 100644 (file)
@@ -94,3 +94,6 @@ will therefore only use a few of them.
 * +FOO_NINJA_ENV+, to specify additional environment variables to pass to
   +ninja+, meson companion tool in charge of the build operations. By default,
   empty.
+
+* +FOO_NINJA_OPTS+, to specify a space-separated list of targets to build. By
+  default, empty, to build the default target(s).
index 507e686068cc548f56bbf8b6db8619affcbd452f..0588660dbf471027bc49286533442b0b3731824b 100644 (file)
@@ -103,12 +103,12 @@ ifndef $(2)_BUILD_CMDS
 ifeq ($(4),target)
 define $(2)_BUILD_CMDS
        $$(TARGET_MAKE_ENV) $$($$(PKG)_NINJA_ENV) \
-               $$(NINJA) $$(NINJA_OPTS) -C $$($$(PKG)_SRCDIR)/build
+               $$(NINJA) $$(NINJA_OPTS) $$($$(PKG)_NINJA_OPTS) -C $$($$(PKG)_SRCDIR)/build
 endef
 else
 define $(2)_BUILD_CMDS
        $$(HOST_MAKE_ENV) $$($$(PKG)_NINJA_ENV) \
-               $$(NINJA) $$(NINJA_OPTS) -C $$($$(PKG)_SRCDIR)/build
+               $$(NINJA) $$(NINJA_OPTS) $$($$(PKG)_NINJA_OPTS) -C $$($$(PKG)_SRCDIR)/build
 endef
 endif
 endif