arptables: add new package
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 30 Oct 2012 02:29:53 +0000 (02:29 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 3 Nov 2012 18:14:18 +0000 (19:14 +0100)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/arptables/Config.in [new file with mode: 0644]
package/arptables/arptables.mk [new file with mode: 0644]

index 3b7458f178e2e64df257c456fa5c83a41b524199..6125abcb82041b52b09a7bd48045b0a353594cd9 100644 (file)
@@ -550,6 +550,7 @@ endmenu
 
 menu "Networking applications"
 source "package/argus/Config.in"
+source "package/arptables/Config.in"
 source "package/avahi/Config.in"
 source "package/axel/Config.in"
 source "package/bluez_utils/Config.in"
diff --git a/package/arptables/Config.in b/package/arptables/Config.in
new file mode 100644 (file)
index 0000000..510eedf
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_ARPTABLES
+       bool "arptables"
+       help
+         Tool to set up, maintain, and inspect the tables of ARP rules.
+
+         http://ebtables.sourceforge.net
diff --git a/package/arptables/arptables.mk b/package/arptables/arptables.mk
new file mode 100644 (file)
index 0000000..dac5ca4
--- /dev/null
@@ -0,0 +1,21 @@
+#############################################################
+#
+# arptables
+#
+#############################################################
+
+ARPTABLES_VERSION = 0.0.3
+ARPTABLES_VERSION_MINOR = 4
+ARPTABLES_SOURCE = arptables-v$(ARPTABLES_VERSION)-$(ARPTABLES_VERSION_MINOR).tar.gz
+ARPTABLES_SITE = http://downloads.sourceforge.net/project/ebtables/arptables/arptables-v$(ARPTABLES_VERSION)
+
+define ARPTABLES_BUILD_CMDS
+       $(MAKE) -C $(@D) \
+               CC="$(TARGET_CC)" COPT_FLAGS="$(TARGET_CFLAGS)"
+endef
+
+define ARPTABLES_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 755 -D $(@D)/arptables $(TARGET_DIR)/usr/sbin/arptables
+endef
+
+$(eval $(generic-package))