civetweb: rename lua option to match naming convention
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 27 Apr 2015 20:29:05 +0000 (22:29 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 27 Apr 2015 20:29:05 +0000 (22:29 +0200)
Suboptions of package foo should be prefixed with BR2_PACKAGE_FOO, not just
BR2_FOO.

Also add Config.in.legacy handling for it.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in.legacy
package/civetweb/Config.in
package/civetweb/civetweb.mk

index 90f474cf0f9a0a81dbeafda9554c05d50feb0d5d..408b5f091005e96bf3ace912344406f50b6ce936 100644 (file)
@@ -107,6 +107,15 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2015.05"
 
+config BR2_CIVETWEB_WITH_LUA
+       bool "civetweb lua option renamed"
+       select BR2_LEGACY
+       select BR2_PACKAGE_CIVETWEB_WITH_LUA
+       help
+         civetweb's lua option has been renamed to
+         BR2_PACKAGE_CIVETWEB_WITH_LUA to be aligned with how other
+         packages name options.
+
 config BR2_PACKAGE_TIFF_TIFF2PDF
        bool "tiff utility-specific option removed"
        select BR2_LEGACY
index 6eed00d16b09c9bcefa392f353958755b3a56420..d68a1ffd53509540016cbe20bdc0f7b348e5d1fe 100644 (file)
@@ -9,7 +9,7 @@ config BR2_PACKAGE_CIVETWEB
 
 if BR2_PACKAGE_CIVETWEB
 
-config BR2_CIVETWEB_WITH_LUA
+config BR2_PACKAGE_CIVETWEB_WITH_LUA
        bool "enable Lua support"
        # required by the bundled Sqlite3 and Lua code
        depends on !BR2_STATIC_LIBS
index eee5cbf05159cbf24986e2b2092c2649a643b1fa..496eef85da0b12768fff544790c870c121ae1e14 100644 (file)
@@ -15,7 +15,7 @@ CIVETWEB_LIBS = -lpthread -lm
 CIVETWEB_SYSCONFDIR = /etc
 CIVETWEB_HTMLDIR = /var/www
 
-ifeq ($(BR2_CIVETWEB_WITH_LUA),y)
+ifeq ($(BR2_PACKAGE_CIVETWEB_WITH_LUA),y)
 CIVETWEB_CONF_OPTS += WITH_LUA=1
 CIVETWEB_LIBS += -ldl
 endif