package/tvheadend: reduce target binary size by using pngquant
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 8 Apr 2017 15:18:04 +0000 (17:18 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 9 Apr 2017 14:05:49 +0000 (16:05 +0200)
Support was added by this commit:
https://github.com/tvheadend/tvheadend/commit/8bf3932539ceadb3bfc1c9453f11175f15aefad2

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/tvheadend/tvheadend.mk

index c2981ff229466c41d40887b012f98c20964d8e7c..0336019bc0c03652ed30147d27007556ed6253af 100644 (file)
@@ -11,6 +11,7 @@ TVHEADEND_LICENSE_FILES = LICENSE.md
 TVHEADEND_DEPENDENCIES = \
        host-gettext \
        host-pkgconf \
+       host-pngquant \
        $(if $(BR2_PACKAGE_PYTHON3),host-python3,host-python) \
        openssl
 
@@ -81,12 +82,19 @@ define TVHEADEND_CONFIGURE_CMDS
                        --python="$(HOST_DIR)/usr/bin/python"   \
                        --enable-dvbscan                        \
                        --enable-bundle                         \
+                       --enable-pngquant                       \
                        --disable-ffmpeg_static                 \
                        --disable-hdhomerun_static              \
                        $(TVHEADEND_CONF_OPTS)                  \
        )
 endef
 
+define TVHEADEND_FIX_PNGQUANT_PATH
+       $(SED) "s%^pngquant_bin =.*%pngquant_bin = '$(HOST_DIR)/usr/bin/pngquant'%" \
+               $(@D)/support/mkbundle
+endef
+TVHEADEND_POST_CONFIGURE_HOOKS += TVHEADEND_FIX_PNGQUANT_PATH
+
 define TVHEADEND_BUILD_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
 endef