Ensure shell environment is handled correctly
authorUlf Samuelsson <ulf.samuelsson@atmel.com>
Sun, 30 Mar 2008 06:38:46 +0000 (06:38 -0000)
committerUlf Samuelsson <ulf.samuelsson@atmel.com>
Sun, 30 Mar 2008 06:38:46 +0000 (06:38 -0000)
Makefile

index 8aad878db119c955206127c1b7e75644305d1679..bfa6a2fadfa738af0de52c42dafe7d3a05105939 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -33,14 +33,10 @@ noconfig_targets:=menuconfig config oldconfig randconfig \
 
 
 # Use shell variables, if defined
-ifneq ($(BUILDROOT_DL_DIR),)
-BR2_DL_DIR:=$(BUILDROOT_DL_DIR)
-endif
-
 ifneq ($(BUILDROOT_LOCAL),)
-LOCAL:=$(BUILDROOT_LOCAL)
+BR2_LOCAL:=$(BUILDROOT_LOCAL)
 else
-LOCAL:=$(TOPDIR)/local
+BR2_LOCAL:=$(TOPDIR)/local
 endif
 
 # $(shell find . -name *_defconfig |sed 's/.*\///')
@@ -51,10 +47,16 @@ ifeq ($(BOARD),)
 -include $(TOPDIR).config
 else
 # if "make" command
--include $(LOCAL)/$(BOARD)/$(BOARD).config
+-include $(BR2_LOCAL)/$(BOARD)/$(BOARD).config
 endif
 endif
 
+# Override BR2_DL_DIR if shell variable defined
+ifneq ($(BUILDROOT_DL_DIR),)
+BR2_DL_DIR:=$(BUILDROOT_DL_DIR)
+endif
+LOCAL:=$(BR2_LOCAL)
+
 # To put more focus on warnings, be less verbose as default
 # Use 'make V=1' to see the full commands
 ifdef V