php-zmq: new package
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 28 Jan 2014 21:26:28 +0000 (18:26 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 12 Feb 2014 14:56:34 +0000 (15:56 +0100)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/php-zmq/Config.in [new file with mode: 0644]
package/php-zmq/php-zmq.mk [new file with mode: 0644]

index fca61d6752921a3d1015b063f6eaa1c48d86cd68..9041059619e856f1ddaef2da8b582fb630e22a37 100644 (file)
@@ -394,6 +394,16 @@ menu "Perl libraries/modules"
 endmenu
 endif
 source "package/php/Config.in"
+if BR2_PACKAGE_PHP
+if !BR2_PREFER_STATIC_LIB
+menu "External php extensions"
+source "package/php-zmq/Config.in"
+endmenu
+endif
+if BR2_PREFER_STATIC_LIB
+comment "External PHP extensions need a toolchain w/ dynamic library"
+endif
+endif
 source "package/python/Config.in"
 if BR2_PACKAGE_PYTHON
 menu "external python modules"
diff --git a/package/php-zmq/Config.in b/package/php-zmq/Config.in
new file mode 100644 (file)
index 0000000..f32b5a3
--- /dev/null
@@ -0,0 +1,17 @@
+comment "php-zmq needs a toolchain w/ C++, IPv6, largefile, wchar, threads"
+       depends on !(BR2_INSTALL_LIBSTDCPP && BR2_INET_IPV6 && BR2_LARGEFILE \
+               && BR2_USE_WCHAR && BR2_TOOLCHAIN_HAS_THREADS)
+
+config BR2_PACKAGE_PHP_ZMQ
+       bool "php-zmq"
+       depends on BR2_PACKAGE_PHP
+       depends on BR2_INSTALL_LIBSTDCPP
+       depends on BR2_INET_IPV6
+       depends on BR2_LARGEFILE # util-linux
+       depends on BR2_USE_WCHAR # util-linux
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       select BR2_PACKAGE_ZEROMQ
+       help
+         ZeroMQ messaging bindings for PHP
+
+         http://pecl.php.net/package/zmq
diff --git a/package/php-zmq/php-zmq.mk b/package/php-zmq/php-zmq.mk
new file mode 100644 (file)
index 0000000..2b48a63
--- /dev/null
@@ -0,0 +1,25 @@
+################################################################################
+#
+# php-zmq
+#
+################################################################################
+
+PHP_ZMQ_VERSION = 1.1.2
+PHP_ZMQ_SOURCE = zmq-$(PHP_ZMQ_VERSION).tgz
+PHP_ZMQ_SITE = http://pecl.php.net/get
+# phpize does the autoconf magic
+PHP_ZMQ_DEPENDENCIES = php zeromq host-autoconf host-pkgconf
+PHP_ZMQ_CONF_OPT = --with-php-config=$(STAGING_DIR)/usr/bin/php-config
+PHP_ZMQ_LICENSE = BSD-3c
+PHP_ZMQ_LICENSE_FILES = LICENSE
+
+define PHP_ZMQ_PHPIZE
+       (cd $(@D); \
+               PHP_AUTOCONF=$(HOST_DIR)/usr/bin/autoconf \
+               PHP_AUTOHEADER=$(HOST_DIR)/usr/bin/autoheader \
+               $(STAGING_DIR)/usr/bin/phpize)
+endef
+
+PHP_ZMQ_PRE_CONFIGURE_HOOKS += PHP_ZMQ_PHPIZE
+
+$(eval $(autotools-package))