libxslt: remove xslt-config script from TARGET_DIR
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 22 Dec 2010 17:23:55 +0000 (18:23 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 7 Mar 2011 21:22:31 +0000 (22:22 +0100)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libxslt/libxslt.mk

index 5fa2f4ce4f995495e0b051632f539117313f4ff7..1efdcf8c255830576ee9d6962fe185125c9bc83f 100644 (file)
@@ -39,5 +39,13 @@ endef
 
 LIBXSLT_POST_INSTALL_STAGING_HOOKS += LIBXSLT_XSLT_CONFIG_FIXUP
 
+define LIBXSLT_REMOVE_CONFIG_SCRIPTS
+       $(RM) -f $(TARGET_DIR)/usr/bin/xslt-config
+endef
+
+ifneq ($(BR2_HAVE_DEVFILES),y)
+LIBXSLT_POST_INSTALL_TARGET_HOOKS += LIBXSLT_REMOVE_CONFIG_SCRIPTS
+endif
+
 $(eval $(call AUTOTARGETS,package,libxslt))
 $(eval $(call AUTOTARGETS,package,libxslt,host))