libucl: add optional libcurl dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 1 Jul 2018 12:52:57 +0000 (14:52 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 1 Jul 2018 12:58:45 +0000 (14:58 +0200)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libucl/libucl.mk

index 087fea683d97144976e8514eef37871dccac661d..9f0378ad9cb57d3d98a8e692dc2c7ed795601c40 100644 (file)
@@ -12,4 +12,11 @@ LIBUCL_LICENSE = BSD-2-Clause
 LIBUCL_LICENSE_FILES = COPYING
 LIBUCL_DEPENDENCIES = host-pkgconf
 
+ifeq ($(BR2_PACKAGE_LIBCURL),y)
+LIBUCL_DEPENDENCIES += libcurl
+LIBUCL_CONF_OPTS += --enable-urls
+else
+LIBUCL_CONF_OPTS += --disable-urls
+endif
+
 $(eval $(autotools-package))