fs/btrfs: remove destination file before generation
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 25 Aug 2018 17:47:14 +0000 (19:47 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 25 Aug 2018 21:59:23 +0000 (23:59 +0200)
btrfs will happily use an existing destination file if it
already exists, increasing its size if needed. Hoever, it
will never decrease the size, even if the requested size
is smaller than the existing file.

So, remove any previously existing destination file before
generating the new filesystem.

Note: the original submission by Robert did that, but as
this case was not obvious, the removal was dropped by a
refactoring when the patch was initially applied.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Robert J. Heywood <robert.heywood@codethink.co.uk>
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
[Thomas: use $@ instead of $(@), use $(RM) instead of rm.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
fs/btrfs/btrfs.mk

index ad00153c26a9a1a9594ab333516c89e1f23e647e..388516389bdf7a2da74101ef0f4dcea4238f49b2 100644 (file)
@@ -29,6 +29,7 @@ BTRFS_OPTS = \
 ROOTFS_BTRFS_DEPENDENCIES = host-btrfs-progs
 
 define ROOTFS_BTRFS_CMD
+       $(RM) -f $@
        $(HOST_DIR)/bin/mkfs.btrfs $(BTRFS_OPTS) $@
 endef